Bug 64121 - Typo on line 299 of /usr/src/linux-2.4.18-0.22/include/linux/module.h
Typo on line 299 of /usr/src/linux-2.4.18-0.22/include/linux/module.h
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-25 19:21 EDT by Michael St. Laurent
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael St. Laurent 2002-04-25 19:21:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I believe there is a typo on line 299 of the /usr/src/linux-2.4.18-
0.22/include/linux/module.h file.  The second quotation should come just before 
the semicolon and not just after the equal sign as it is in the beta test 
version.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit the file and look.
2.
3.
	

Additional info:
Comment 1 Arjan van de Ven 2002-04-25 19:29:13 EDT
Humm it actually looks correct
it basically creates a string which is "kernel_version=2.4.18-0.22";
C allows 2 string constants to be consecutive and then concatinates them
underwater...
Comment 2 Michael St. Laurent 2002-04-25 19:38:31 EDT
On my system the line reads:

"kernel_version=" UTS_RELEASE;

This caused the compiler to error out with something like 'Parse error before 
UTS_RELEASE'  When I changed the line to read like this:

"kernel_version=UTS_RELEASE";

the compiler was happy.
Comment 3 Arjan van de Ven 2002-04-26 02:22:51 EDT
The compiler might be happy but it's wrong.
UTS_RELEASE is a string with the kernel version number, and that needs to be
concatinated there, eg to create "kernel_version=2.4.18-0.22".
Now UTS_RELEASE is from version.h which is autogenerated at build time;
could you say how you are building the kernel since I get the idea something is
going funny there that causes a weird version.h to be present
Comment 4 Michael St. Laurent 2002-04-26 11:52:36 EDT
I'm not actually building the kernel, I'm building the linux-wlan-ng package 
which requires the kernel and pcmcia-cs sources (which it borrows files from).
Comment 5 Arjan van de Ven 2002-04-26 11:54:47 EDT
linux-wlan-ng is broken then. 
It should not ever depend on the kernel sources.
It can use the glibc headers (from glibc-devel and glibc-kernheaders).....

Note You need to log in before you can comment on or make changes to this bug.