Bug 64138 - ucd-snmp-util needs un-installed perl SNMP.pm
ucd-snmp-util needs un-installed perl SNMP.pm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-26 09:42 EDT by Francois-Xavier 'FiX' KOWALSKI
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-28 06:00:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francois-Xavier 'FiX' KOWALSKI 2002-04-26 09:42:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417

Description of problem:
mib2c, the SNMP MIB-to-C-code translater needs a perl module named SNMP.pm in
order to run properly.  mib2c is part of ucd-snmp-utils packages.

The error message is as follows:

[fxk@tarifa1 fxk]% mib2c                  

ERROR: You don't have the SNMP perl module installed.  Please obtain
this by getting the latest source release of the ucd-snmp toolkit from
http://www.net-snmp.org/download/ .  The perl module is contained in
the perl/SNMP directory.  See the INSTALL file there for instructions.

I suppose that the build machine (stripples.devel.redhat.com) where the package
was built has this SNMP.pm installed, but not in the build environment...

Looking into the /usr/lib/perl5 directory structure, it appears that the file is
missing.

Looking at the RedHat 7.2 packages & update packages, it appears that no perl
extension package provides the SNMP.pm file.

[fxk@tarifa1 perl5]% cd /usr/lib/perl5 
[fxk@tarifa1 perl5]% find . -name SNMP.pm  
[fxk@tarifa1 perl5]% 

ucd-snmp-utils pre-installation script should check for the presence of SNMP.pm.
Alternatively, the ucd-snmp-utils ".spec" script should look for Perl packages
dependencies when building ucd-snmp-utils binary package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install ucd-snmp-utils
2. run "mib2c"
3. fix that stuff... :-)



Actual Results:  [fxk@tarifa1 perl5]% mib2c

ERROR: You don't have the SNMP perl module installed.  Please obtain
this by getting the latest source release of the ucd-snmp toolkit from
http://www.net-snmp.org/download/ .  The perl module is contained in
the perl/SNMP directory.  See the INSTALL file there for instructions.

[fxk@tarifa1 perl5]% 


Expected Results:  something like a help / synopsis output, giving a bit more...

Additional info:

The severity field below does not provide something like "the functionnality of
the component is OOS, but the system can still operate normally", so I fill that
bug as "Normal".
Comment 1 Phil Knirsch 2002-05-21 08:01:53 EDT
OK, i've updated the ucd-snmp package to the latest release. I'll verify myself
that the perl-SNMP module builds with that one and works and will close this bug
if it passes the make test.

Read ya, Phil
Comment 2 Phil Knirsch 2003-03-28 06:00:08 EST
n the next upcoming release we will provide a net-snmp-package again coming
along with the net-snmp package.

A rawhide version will be available soon.

Read ya, Phil
Comment 3 Francois-Xavier 'FiX' KOWALSKI 2003-03-28 08:40:35 EST
There might be a mis-understanding there.  The problem is that net/ucd-snmp
utility mib2c (provided by RedHat) does not work in absence of perl-SNMP (which
is not provided by RedHat AFAIK) not the opposite.

Hope things are clarified.
Comment 4 Phil Knirsch 2003-03-28 08:44:58 EST
Sure. Thats why in the next release this utility will be packaged into the
net-snmp-perl package in order to fullfill this requirement.

Or am i missing something else here? :-)

Read ya, Phil
Comment 5 Francois-Xavier 'FiX' KOWALSKI 2003-03-28 11:33:02 EST
No this is fine.  Any chance to get this back-ported on ucd-snmp on our
(supported) RHAS-2.1 systems (ia32 & ia64)?
Comment 6 Phil Knirsch 2003-03-28 11:46:06 EST
I've just looked at the latest errata we have released for AS2.1 and it already
contains a perl subdirectory like the net-snmp version.

So i guess it should be doable, haven't verified it yet though.

I'll present it to our AS2.1 feature meeting in 2 weeks and see to get a GO for
it. Shouldn't be a problem i guess, but i'll let you know here when i know more.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.