Bug 64165 - Add DVD+RW tools to distribution.
Add DVD+RW tools to distribution.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dvdrtools (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-26 20:55 EDT by Chris Kloiber
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 14:36:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2002-04-26 20:55:55 EDT
Description of Problem: 
 
Installed new HP 100i DVD+RW burner, and it seems to work unless I try to burn 
an image larger than "100 minutes" to a DVD+RW media. dvdrecord bombs out with 
the message: 
 
[root@ckk skipjack]# dvdrecord -vv -eject -dao driver=mmc_cd_dvd \ 
Skipjack-i386-dvd.iso 
dvdrtools v0.1.3 
Portions (c) 2002 Red Hat, Inc. 
Based on: 
Cdrecord 1.11a15 (i386-redhat-linux-gnu) Copyright (C) 1995-2001 Jvrg 
Schilling 
TOC Type: 1 = CD-ROM 
scsidev: '1,0,0' 
scsibus: 1 target: 0 lun: 0 
Linux sg driver version: 3.1.22 
Using libscg version 'schily-0.5' 
Using libscg transport code version 'schily-scsi-linux-sg.c-1.69' 
atapi: 1 
Device type    : Removable CD-ROM 
Version        : 0 
Response Format: 2 
Capabilities   : 
Vendor_info    : 'HP      ' 
Identifikation : 'DVD Writer 100j ' 
Revision       : '1.34' 
Device seems to be: Generic mmc2 DVD-ROM. 
dvdrecord: WARNING: Trying to use other driver on known device. 
Using generic SCSI-3/mmc CD/DVD driver (checks media) (mmc_cd_dvd). 
Driver flags   : SWABAUDIO 
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R96R 
FIFO size      : 4194304 = 4096 KB 
Track 01: data  1544 MB 
track: 1 start: 0 pregap: 150 
Total size:     1773 MB (175:42.93) = 790720 sectors 
Lout start:     1773 MB (175:44/70) = 790720 sectors 
 41 00 00 14 00 00 00 00 
 41 01 00 10 00 00 00 00 
 41 01 01 10 00 00 02 00 
 41 AA 01 14 00 AF 2C 46 
Track 1 start 0 
Track 2 start 790720 
 41 00 A0 00 00 00 00 01 00 00 00 00 
 41 00 A1 00 00 00 00 01 00 00 00 00 
 41 00 A2 00 00 00 00 FF 44 70 00 00 
 41 00 01 00 00 00 00 00 02 00 00 00 
Current Secsize: 2048 
dvdrecord: Unspecified command not implemented for this drive. 
dvdrecord: Data will not fit on any disk. 
dvdrecord: Cannot write CD's >= 100 minutes. 
  
* Does the same thing if I don't specify the driver= except it's detected as a 
mmc2/CD-R drive.su -
Comment 1 Chris Kloiber 2002-04-27 15:08:22 EDT
Found a small kernel patch for the sr module that enables you to simply cat or 
dd an image to the DVD+RW drive. It applies cleanly w/fuzz to the 2.4.18-X 
kernels and seems to work just fine. Also includes userspace tools to format 
DVD+RW disks (does not require kernel patch) and Location is: 
 
http://fy.chalmers.se/~appro/linux/DVD+RW/
Comment 2 Chris Kloiber 2002-08-24 21:03:56 EDT
This is still the case with (null).
Comment 3 Chris Kloiber 2002-09-26 12:59:32 EDT
Kernel patch not required. Userland tools work without kernel modification now,
same URL.
Comment 4 Mike A. Harris 2002-09-29 13:11:23 EDT
Hi Chris,

I'd just like to verify what you're asking for here as I've just
been assigned this package.  You're wanting the DVD+RW tools at the
above URL to be added to the distribution?
Comment 5 Chris Kloiber 2002-09-29 23:11:02 EDT
Yes, if they pass technical muster. DVD+RW drives are not compatible with
dvdrecord, cdrecord or cdrdao for writing DVD+R or DVD+RW disks (they work fine
with them for burning standard CD's). I have had no trouble with writing DVD+RW
disks using these userland tools. The kernel patch is not needed, but with it it
is possible to simply 'dd' a DVD iso to the drive and it will write. That
funcionality is accomplished using growisofs in userland, and seems a better
move. I had made a simple RPM of these for my own use (on my ftp://people page)
but I have not checked for updates since then.
Comment 6 Chris Kloiber 2002-11-08 17:33:00 EST
The author of the code I packaged wrote me to say he has updated the code, and
created a (hopefully) proper Makefile and .spec file and it is available on his
website noted above. He would be really happy if Red Hat picked up his project
and made it a part of the distribution.
Comment 7 Harald Hoyer 2003-03-10 10:15:12 EST
assigning to master of os-develdept :)
Comment 8 Chris Kloiber 2003-03-10 12:33:15 EST
FYI- since my lst update, support was added to dvd+rw-tools for DVD-RW and DVD-R
in addition to DVD+RW and DVD+R. A src.rpm and i386.rpm of his latest code (as
of Feb.28,2003) is available on my people page.

ftp://people.redhat.com/ckloiber/dvd+rw-tools-5.2.4.1.4/
Comment 9 Matt Wilson 2003-10-16 14:36:15 EDT
included in RHEL 3 and Fedora Core 1

Note You need to log in before you can comment on or make changes to this bug.