Bug 641858 - virt-manager specified incorrect disk driver when changing media for guest.
virt-manager specified incorrect disk driver when changing media for guest.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.6
All Linux
high Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
: 679292 704863 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 06:35 EDT by Johnny Liu
Modified: 2011-08-03 11:53 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 07:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2010-10-11 06:35:30 EDT
Description of problem:
virt-manager specify incorrect disk driver when change media for guest.

Version-Release number of selected component (if applicable):
libvirt-0.8.2-6.el5
virt-manager-0.6.1-13.el5
# uname -a
Linux localhost.localdomain 2.6.18-225.el5 #1 SMP Mon Sep 27 10:32:19 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Always

Steps to Reproduce:
1. Lauch virt-manager, select a guest which has a cdrom device, go to Hardware tab.
2. Select the cdrom device, disconnect the original media. 
3. Connect "an iso image file" or "physical cdrom (/dev/sr0)" to the cdrom device, and dumpxml the xml.
4. Try to start the domain.
  
Actual results:
When connect "an iso image file" to the cdrom device, the following xml is seen:
# virsh dumpxml rhel5u5|grep -A 6 cdrom
    <disk type='file' device='cdrom'>
      <driver name='file' type='raw'/>
      <source file='/var/lib/libvirt/images/RHEL5.5-Server-20100322.0-x86_64-DVD.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>

In the line - "<driver name='file' type='raw'/>", driver name is incorrect, should be "qemu".


When connect "physical cdrom (/dev/sr0)" to the cdrom device, the following xml is seen:
# virsh dumpxml rhel5u5|grep -A 6 cdrom
    <disk type='block' device='cdrom'>
      <driver name='phy' type='raw'/>
      <source dev='/dev/sr0'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>

In the line - "<driver name='phy' type='raw'/>", driver name is incorrect, should be "qemu".

And failed to start the domain.

Expected results:
The disk driver should be qemu, and start the domain successfully after change the media fo guest.

Additional info:
Comment 2 RHEL Product and Program Management 2010-12-07 05:33:02 EST
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 4 Mark Wu 2011-02-11 03:13:23 EST
It looks already fixed in BZ516116
Comment 7 Cole Robinson 2011-03-09 17:55:07 EST
*** Bug 679292 has been marked as a duplicate of this bug. ***
Comment 9 Cole Robinson 2011-04-29 10:19:30 EDT
Sorry for not replying earlier, but I've now built a fix for this, so it should be in 5.7.

Fixed in virt-manager-0.6.1-14.el5
Comment 11 Huming Jiang 2011-05-05 04:06:34 EDT
Reproduce:
virt-manager-0.6.1-13.el5
libvirt-0.8.2-18.el5

Verfied it on build :
virt-manager-0.6.1-14.el5
libvirt-0.8.2-18.el5

Steps:
1. Lauch virt-manager, select a guest which has a cdrom device, go to Hardware
tab.
2. Select the cdrom device, disconnect the original media. 
3. Connect "an iso image file" or "physical cdrom (/dev/sr0)" to the cdrom
device, and dumpxml the xml.
4. The domain could be successfully started.
Comment 12 Huming Jiang 2011-05-05 05:02:46 EDT
Verification process in detail:

Reproduce:
virt-manager-0.6.1-13.el5
libvirt-0.8.2-18.el5

Verified it on build :
virt-manager-0.6.1-14.el5
libvirt-0.8.2-18.el5

Steps:
1. Lauch virt-manager, select a guest which has a cdrom device, go to Hardware
tab.
2. Select the cdrom device, disconnect the original media. 
3. Connect "an iso image file" or "physical cdrom (/dev/sr0)" to the cdrom
device, and dumpxml the xml.

xml file about cdrom:
       <disk type='block' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source dev='/dev/sr0'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <alias name='ide1-cd0'/>
      <address type='drive' controller='0' bus='1' unit='0'/>
      </disk>
xml file about iso image:
   <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/home/RHEL5.6-Server-20110106.0-x86_64-DVD.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <alias name='ide1-cd0'/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>

     
4. The domain could be successfully started.
Comment 13 Cole Robinson 2011-07-12 19:22:52 EDT
*** Bug 704863 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2011-07-21 07:16:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1055.html

Note You need to log in before you can comment on or make changes to this bug.