Bug 64197 - libgr-2.0.13-23 won't build as non-root
libgr-2.0.13-23 won't build as non-root
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: libgr (Show other bugs)
6.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-28 17:34 EDT by Ed Avis
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2002-04-28 17:34:36 EDT
As a non-root user, run 'rpm --rebuild libgr-2.0.13-23.src.rpm'.  It works okay
until the end, when libgr-scripts/install.sh spits out lots of errors.  It is
trying to 'install' files into /var/tmp owned by root.  (This is not necessary
because the file ownership can be set in the spec file.)

Patch to fix it (if you care to):

diff -ru libgr-2.0.13/libgr-scripts/install.sh
libgr-2.0.13-new/libgr-scripts/install.sh
--- libgr-2.0.13/libgr-scripts/install.sh	Thu Nov  6 19:46:02 1997
+++ libgr-2.0.13-new/libgr-scripts/install.sh	Sun Apr 28 21:25:02 2002
@@ -8,11 +8,11 @@
 mkdir -p $DEST/usr/bin $DEST/usr/man/man1
 
 for i in $SCRIPTS; do
-	install -m 755 -o root -g root $i $DEST/usr/bin
+	install -m 755 $i $DEST/usr/bin
 done
 
 for i in $MANS; do
-	install -m 644 -o root -g root $i $DEST/usr/man/man1
+	install -m 644 $i $DEST/usr/man/man1
 done
 

This to be applied after unpacking the libgr-scripts.tar.gz tarball.
Comment 1 Bill Nottingham 2006-08-07 15:36:33 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 12:54:15 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.