Bug 641980 - mouse does not work in virt guests
mouse does not work in virt guests
Status: CLOSED DUPLICATE of bug 636887
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 13:17 EDT by John Poelstra
Modified: 2013-01-09 06:41 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 15:25:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2010-10-11 13:17:20 EDT
Description of problem:
mouse does not work (move) in virt guests.  

Version-Release number of selected component (if applicable):
$ rpm -qa | grep virt | sort
libvirt-0.8.3-2.fc14.x86_64
libvirt-client-0.8.3-2.fc14.x86_64
libvirt-python-0.8.3-2.fc14.x86_64
python-virtinst-0.500.4-1.fc14.noarch
python-virtkey-0.50-8.fc14.x86_64
virt-manager-0.8.5-1.fc14.noarch

How reproducible:
100%

Tried with Fedora 14 guest and Ubuntu 10.10 guest


Steps to Reproduce:
1. run virt-manager
2. boot live media
3. mouse doesn't move
Comment 1 John Poelstra 2010-10-11 13:20:20 EDT
FWIW, keyboard does work.
Comment 2 Cole Robinson 2010-10-11 13:28:34 EDT
I think this is a qemu issue. Latest QEMU has broken non-tablet mouse according to Gerd's patch series upstream:

http://lists.nongnu.org/archive/html/qemu-devel/2010-10/msg00410.html

We should really make sure that series is applied for F14.
Comment 3 Daniel Berrange 2010-10-11 13:34:10 EDT
Smells like a dup of bug 636887
Comment 4 Daniel Berrange 2010-10-11 13:34:57 EDT
Checking the Xorg.0.log from the guest to see if it activated 'vmmouse' will confirm whether its the same issue.
Comment 5 John Poelstra 2010-10-11 14:31:49 EDT
After discussing more on #fedora-qa we determined this was a result of me NOT specifying the OS and Version in the virt-manager GUI.

I created a new guest by correctly specifying OS=Linux and Version=Fedora 14 and mouse works fine.

I created a new guest and specified OS=Linux and Version=Ubuntu 10.4 and ran Ubuntu 10.10 install and mouse does NOT work.

Removing F14Blocker.
Comment 6 Daniel Berrange 2010-10-12 06:04:03 EDT
If you didn't select an OS type, then instead of getting a USB tablet, you would have got the default QEMU mouse which is PS/2 + vmmouse extensions. So I still reckon you were hitting the QEMU bug i mention. Xorg.0.log can confirm.
Comment 7 Justin M. Forbes 2010-10-19 15:25:37 EDT

*** This bug has been marked as a duplicate of bug 636887 ***

Note You need to log in before you can comment on or make changes to this bug.