This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 64204 - gnorpm segfaults when checking gpg signatures
gnorpm segfaults when checking gpg signatures
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-29 03:23 EDT by reeftiger
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-19 11:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description reeftiger 2002-04-29 03:23:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
gnorpm-0.96-14 segfaults every time that it attempts to verify gpg signatures

rpm-4.0.4-7x
gnupg-1.0.6-1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start gnorpm
2. Select GPG signed packages to install/upgrade
3. Check sinature
	Or
1. Select GPG signed RPM package in GMC
2. Right click and select "Check Signature....."
        Or
2. Right click and select "Show Info......."
3. Click "Check Sig"

Actual Results:  Segfault

Expected Results:  Check signatures, return "md5 OK" and "size Ok" and
"unknown   unknown signature"

Additional info:

gnorpm-0.96-14 (rawhide, upgraded from gnorpm-0.96-12.7x after having same
results)
rpm-4.0.4-7x
gnupg-1.0.6-1



Distribution: Red Hat Linux release 7.1 (Seawolf)
System: Linux 2.4.9-31 i686 unknown
C library: glibc-2.2.4-24
C compiler: 2.96
glib: 1.2.9
GTK+: 1.2.9
ORBit: ORBit 0.5.7
gnome-libs: gnome-libs 1.2.8
libxml: 1.8.10
gnome-print: gnome-print-0.25
gnome-core: gnome-core 1.2.4


Description:
gnorpm segfaults every time when attemping to verify gpg signature


Debugging information:
(no debugging symbols found)...
Core was generated by `gdb --batch --quiet
--command=/usr/share/bug-buddy/gdb-cmd /usr/bin/gnorpm 1705'.
Program terminated with signal 6, Aborted.
(no debugging symbols found)...#0  0x400c8b01 in __kill ()
   from /lib/i686/libc.so.6
#0  0x400c8b01 in __kill () from /lib/i686/libc.so.6
#1  0x400c88da in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x400ca082 in abort () at ../sysdeps/generic/abort.c:88
#3  0x080d80cf in internal_verror ()
#4  0x080d8126 in internal_error ()
#5  0x080aedcd in lin_lwp_detach ()
#6  0x080f6b42 in thread_db_detach ()
#7  0x080bb2f9 in target_detach ()
#8  0x080d6da3 in quit_force ()
#9  0x080d59f8 in execute_command ()
#10 0x080d5c32 in command_loop ()
#11 0x080d57e1 in read_command_file ()
#12 0x0813b9ee in script_from_file ()
#13 0x0813bf55 in source_command ()
#14 0x080d56b8 in do_captured_command ()
#15 0x080d5689 in catch_errors ()
#16 0x080d570a in catch_command_errors ()
#17 0x0806fad9 in captured_main ()
#18 0x080d5689 in catch_errors ()
#19 0x0806fc38 in main ()
#20 0x400b6647 in __libc_start_main (main=0x806fc00 <main>, argc=6, 
    ubp_av=0xbfffe7e4, init=0x806e620 <_init>, fini=0x81a3bd8 <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbfffe7dc)
    at ../sysdeps/generic/libc-start.c:129
#0  0x400c8b01 in __kill () from /lib/i686/libc.so.6
No locals.
#1  0x400c88da in raise (sig=6) at ../sysdeps/posix/raise.c:27
        in ../sysdeps/posix/raise.c
No locals.
#2  0x400ca082 in abort () at ../sysdeps/generic/abort.c:88
        in ../sysdeps/generic/abort.c
act = {__sigaction_handler = {sa_handler = 0x401cef80 <_IO_2_1_stderr_>, 
    sa_sigaction = 0x401cef80 <_IO_2_1_stderr_>}, sa_mask = {__val = {
      136290998, 1, 1074881678, 136858360, 1075638944, 3221217784, 1, 0, 0, 
      136290998, 1075645908, 1075638144, 1073833280, 1073835008, 1073838752, 
      3221217856, 1073795910, 1073835420, 1073838784, 1, 0, 1, 1, 0, 0, 
      136360856, 134618713, 1074397300, 1, 0, 0, 3221217912}}, 
  sa_flags = 1073796320, sa_restorer = 0x1}
sigs = {__val = {32, 0 <repeats 31 times>}}
#3  0x080d80cf in internal_verror ()
No symbol table info available.
#4  0x080d8126 in internal_error ()
No symbol table info available.
#5  0x080aedcd in lin_lwp_detach ()
No symbol table info available.
#6  0x080f6b42 in thread_db_detach ()
No symbol table info available.
#7  0x080bb2f9 in target_detach ()
No symbol table info available.
Comment 1 Havoc Pennington 2002-07-06 18:12:15 EDT
gnorpm has been removed in rawhide, working on a replacement.
Comment 2 reeftiger 2002-07-13 18:11:31 EDT
I have since upgraded to 7.3 and encounter the same (similar) problem on some
signed packages. New bug report?
Comment 3 Havoc Pennington 2002-07-13 18:33:45 EDT
Most likely this will just be resolved by replacing gnorpm in the upcoming
release, so a new bug report is not necessary.

Note You need to log in before you can comment on or make changes to this bug.