Bug 642073 - pdftops doesn't handle changes in page size or orientation
pdftops doesn't handle changes in page size or orientation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
: Patch
Depends On: 643105 643389
Blocks: 668957 743405 1002709
  Show dependency treegraph
 
Reported: 2010-10-11 17:55 EDT by Bryan Mason
Modified: 2013-10-06 21:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:43:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
landrait.pdf (8.34 KB, application/octet-stream)
2010-10-15 06:59 EDT, Tim Waugh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3689 None None None Never

  None (edit)
Description Bryan Mason 2010-10-11 17:55:02 EDT
Description of problem:

    The version of pdftops based on xpdf could handle changes in page
    sizes and orientation within the PDF file.  That is to say, if the
    first page of a PDF file was landscape and the second was
    portrait, the xpdf-based pdftops would generate a PostScript file
    whose first page was landscape and second was portrait.

    However, it appears that the current poppler-based pdftops filter
    cannot do this.

Version-Release number of selected component (if applicable):

    cups-1.3.7-18.el5_5.7

How reproducible:

   100%

Steps to Reproduce:

    1. Try to print a pdf file with varying page orientations (or sizes).
  
Actual results:

    All pages printed will have the orientation of the first page.

Expected results:

    Pages with different orientations will be printed properly.

Additional info:

This issue appears to have been addressed in upstream poppler with the addition of an -origpagesizes option.

See:

https://bugs.freedesktop.org/show_bug.cgi?id=19777

and
  
http://cgit.freedesktop.org/poppler/poppler/commit/?id=2cf9e6a2318b770ae62572944c687576d1801d31

Although upstream CUPS doesn't seem to use the -origpagesizes option.
Comment 5 Tim Waugh 2010-10-12 08:45:14 EDT
I haven't been able to see what is wrong with the output.

I created a PDF file 'portscape.pdf' in OpenOffice.org, by typing "Portrait", then inserting a manual page break to style "Landscape", then typing "Landscape" and exporting to PDF.

I've printed this to a variety of printers, each using a different driver type, and don't see any problem.

Can you explain the symptom please?
Comment 6 Bryan Mason 2010-10-12 15:08:53 EDT
After creating this Bug, I ran the same test (creating a PDF with OpenOffice) and came up with the same results.  I just didn't have time to update the Bug -- you beat me to it. :)

The symptom is that I have a PDF which both gs and evince will display the first page as landscape and the second page as portrait.  However, when I print the document using lp, both pages are printed portrait. (Interestingly, when the customer prints using lp, both pages are landscape.)

If the file is printed from evince, then it is displayed properly.

Printing was working correctly for the customer in RHEL 5.4, so I'm assuming that the switch from the xpdf-based pdftops to the poppler-based filter is causing some issues.  Based on that assumption, I thought that the older pdftops had some sort of feature that did something similar to the "-origpagesizes" option in poppler.

I'll upload the PDF shortly.
Comment 8 Tim Waugh 2010-10-15 06:59:46 EDT
Created attachment 453704 [details]
landrait.pdf

Looks like this PDF causes the same problem.  This is landscape on page 1 and portrait on page 2.

The symptom is that page 2 is actually rotated, so that instead of:

+------+
|  Po  |
|  rt  |
|  ra  |
|  it  |
+------+

we get this:

+----------+
|    Po    |
|    rt    |
+----------+
Comment 10 RHEL Product and Program Management 2011-05-31 10:17:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 RHEL Product and Program Management 2012-04-02 06:44:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 17 RHEL Product and Program Management 2012-10-26 14:19:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 23 RHEL Product and Program Management 2013-05-01 03:13:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 25 Andrius Benokraitis 2013-10-06 21:43:07 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.