Bug 64389 - installation put malformed data in ifcfg-eth0
Summary: installation put malformed data in ifcfg-eth0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-03 14:33 UTC by John Shriver
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-09 19:02:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Shriver 2002-05-03 14:33:02 UTC
Did install from CD, using default X GUI install.  (Don't know the exact name of
this component, since I don't even know the path said application during the
install boot.)

The eth0 interface didn't get an IP address configured, even though I entered
one in the GUI.  (I didn't choose DHCP.)  The reason is that apparently I put a
space at the front of the IP address in the GUI config, and the file
/etc/sysconfig/network-scripts/ifcfg-eth0 winds up with the line:

IPADDR= 192.168.1.49

Note the space between = and 1.

This causes "/etc/sysconfig/network-scripts/ifup eth0" to spit the errors:

/etc/sysconfig/network-scripts/ifup-post: 192.168.1.49: command not found
/etc/sysconfig/network-scripts/ifup-aliases: 192.168.1.49: command not found

More importantly, no IP address is assigned to the interface.

The fix is pretty obvious -- better checking of input data in GUI install
screen.

(Workaround is obvious to, but only to a programmer.)

Comment 1 Michael Fulbright 2002-05-09 19:02:07 UTC
Thanks we'll look into it.

Comment 2 Michael Fulbright 2002-06-21 05:51:20 UTC
We have changed the IP entry so it is not possible to enter spaces.

Comment 3 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.