Bug 64409 - Driver build problem for kernel 2.4.9-21 and 9-31
Driver build problem for kernel 2.4.9-21 and 9-31
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-03 16:25 EDT by Mike Reyero
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-03 17:25:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a detailed description of the problem I am experiencing (5.08 KB, text/plain)
2002-05-03 16:28 EDT, Mike Reyero
no flags Details

  None (edit)
Description Mike Reyero 2002-05-03 16:25:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
In order for me to build my driver that supports the 2.4.9-21 and 9-31 kernel, 
I must be booted under the correct kernel image. This is even though I am 
pointing to the correct kernel tree. I will attach a more extensive description 
when I receive the response message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. You will be unable to reproduce this problem with out my source 
code
2.
3.
	

Additional info:
Comment 1 Mike Reyero 2002-05-03 16:28:46 EDT
Created attachment 56304 [details]
This is a detailed description of the problem I am experiencing
Comment 2 Arjan van de Ven 2002-05-03 16:56:24 EDT
Ok it looks like you are following the wrong procedure to build drivers.
One does NOT need to rebuild or reconfigure ANYTHING in /usr/src/linux-2.4.X-Y
to build drivers against it. All needed info for the shipped kernels is already
in there
and will be DESTROYED if you reconfigure the kernel.

And yes to use that info it's simplest to reboot into the relevant kernel; it
then Just Works(tm).
That's how it's designed, so that people can have modules that auto-build on
boot (when needed).
I assume you ship source with your module; we can help you to get such an
auto-building set up.
Comment 3 Mike Reyero 2002-05-03 17:25:06 EDT
We do not provide kernel source for our driver. In addition, I can not build my 
driver if I simply load the kernel source (via the rpm) on my build system. It 
does not know whether I am building for an smp or uniprocessor. I use spinlocks 
so this is important. Also, the modules directory which contains the name 
mangling is not present so this will cause a problem until I run the "make dep" 
as I described in the attachment. Also, can you explain why this problem only 
occurs on the 9-21 and 9-31 kernels? (please see description in the attachment) 
I do not experience this problem on the other Redhat kernels (2-2 and 7-10) and 
I followed the exact same steps as described in the attachment.
Comment 4 Michael K. Johnson 2002-05-03 17:43:39 EDT
This process works for us in our testing.  Without a reproducer,
there is no way we can help.  It sounds like you need support,
rather than a bug fix, and we do have a support department who
have the skills needed to help you.

Note You need to log in before you can comment on or make changes to this bug.