Bug 644145 - cairo.h has an enum with a trailing comma
cairo.h has an enum with a trailing comma
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
:
: 644144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-18 22:14 EDT by Ben Boeckel
Modified: 2011-06-25 14:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-25 14:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch cherry-pick'd from upstream (commit 8fca990) (788 bytes, patch)
2010-10-18 22:15 EDT, Ben Boeckel
no flags Details | Diff

  None (edit)
Description Ben Boeckel 2010-10-18 22:14:15 EDT
Description of problem:
When compiling with -ansi -pedantic -Werror (working on packaging a project that uses these flags), the cairo.h header has a trailing comma in an enum.

Patch attached (cherry-pick'd from upstream).

Version-Release number of selected component (if applicable):
cairo-1.10.0-1.fc14.x86_64
Comment 1 Ben Boeckel 2010-10-18 22:15:11 EDT
Created attachment 454236 [details]
Patch cherry-pick'd from upstream (commit 8fca990)
Comment 2 Ben Boeckel 2010-11-04 11:46:48 EDT
*** Bug 644144 has been marked as a duplicate of this bug. ***
Comment 3 Ben Boeckel 2011-06-25 14:36:28 EDT
Seems to be fixed in newer versions (cairo-1.10.2-3.fc15 at the latest).

Note You need to log in before you can comment on or make changes to this bug.