Bug 64445 - Internal compiler error in fixup_var_refs_1
Internal compiler error in fixup_var_refs_1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://drip.sourceforge.net/download.php
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-05 09:58 EDT by Bruce Garlock
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 15:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Here is a very small C source file that shows the problem. (822 bytes, text/plain)
2002-07-10 22:02 EDT, Edward A. Falk
no flags Details

  None (edit)
Description Bruce Garlock 2002-05-05 09:58:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
I recieve the folowing when trying to compile drip from CVS:

In file included from swscale.cpp:469:
swscale_template.cpp: In function `void SwScale_YV12slice_MMX2
(unsigned char **, int *, int, int, uint8_t **, int, int, int, int,
int, int)':
swscale_template.cpp:2580: Internal compiler error in fixup_var_refs_1,
at function.c:1874
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [libencoder_la-swscale.lo] Error 1
make[2]: Leaving directory `/home/bruceg/drip/encoder'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/bruceg/drip'
make: *** [all] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to compile drip
2.
3.
	

Actual Results:  error, as stated above

Expected Results:  compile drip successfully.

Additional info:
Comment 1 Wm. Josiah Erikson 2002-07-01 21:45:09 EDT
I have this exact problem. I will include the command immediately previous for
clarity.
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include -DARCH_X86 -funroll-all-loops
-fomit-frame-pointer -g3 -ggdb3 -I/usr/local/include/avifile
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/gnome-1.0
-DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2
-I/usr/X11R6/include -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-D_USE_LARGEFILE64 -pthread -I/usr/local/include -I/usr/include
-I/usr/include/gdk-pixbuf-1.0 -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include -I../libspu/ -g -O2 -c swscale.cpp
-MT libencoder_la-swscale.lo -MD -MP -MF .deps/libencoder_la-swscale.TPlo  -fPIC
-DPIC -o .libs/libencoder_la-swscale.lo
In file included from swscale.cpp:469:
swscale_template.cpp: In function `void SwScale_YV12slice_MMX2 
(unsigned char **, int *, int, int, uint8_t **, int, int, int, int, 
int, int)':
swscale_template.cpp:2580: Internal compiler error in fixup_var_refs_1, 
at function.c:1874
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [libencoder_la-swscale.lo] Error 1
make[2]: Leaving directory `/home/josiah/drip/encoder'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/josiah/drip'
make: *** [all] Error 2


I guess I will try gcc3 or switch to debian.
Comment 2 Edward A. Falk 2002-07-10 22:02:34 EDT
Created attachment 64706 [details]
Here is a very small C source file that shows the problem.
Comment 3 Bruce Garlock 2002-07-20 10:19:01 EDT
Looks like the newest drip pre-release (drip-0.8.2pre1) addresses this issue.  I
was able to get past the error, when configuring drip like this:

./configure --without-pic

HTH...

- Bruce
Comment 4 Alan Cox 2002-12-15 15:11:27 EST
Verified ok in 8.0

Note You need to log in before you can comment on or make changes to this bug.