Bug 64471 - servers time is not set correctly in linuxconf
servers time is not set correctly in linuxconf
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-06 02:08 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 17:32:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-06 02:08:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 (Macintosh; U; PPC)

Description of problem:
when using linuxconf (date&time)
with a time server, and time set to localtime.
 clicking on the accept:
executes
  /sbin/rdate	[timeserver]
 however it should execute
 /sbin/rdate -s [timeserver] so that the time gets set and not just
 displayed
 
 then the following command
 /sbin/clock -w --localtime stores the time correctly
 
 
 as it is its just storing the time that is already set, which may or may not be 
correct, and defeats the whole point of the exercise.

or should the user get a message to re-boot the server to install the new time, 
so that the server does not get confused , with cronjobs etc.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
see above
	

Actual Results:  time is  only displayed but not set

Expected Results:  time should be set, or a message asking the user to re-boot 
the server to take up the new time

Additional info:


i have classed it as high, because if the server is not setting its time 
correctly, both my backups and my oracle database are running with incorrect 
info, which in the case of oracle can result in lost/corrupted data.
Comment 1 Brent Fox 2002-06-05 12:15:56 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Need Real Name 2002-06-05 20:03:43 EDT
sorry that does not cut it  ,as regards a valid bug.

but if you insist in taking this attitude towards valid bugs, then you can 
consider your product range dropped  from further use by my consultancy.
have a nice day
Comment 3 Bill Nottingham 2003-08-11 17:32:57 EDT
As stated, linuxconf is not part of our products since Red Hat Linux 7.3, so we
aren't going to fix most linuxconf bugs in older releases.

Note You need to log in before you can comment on or make changes to this bug.