This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 645096 - Backport vdagent channel fixes from master
Backport vdagent channel fixes from master
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-20 16:02 EDT by Hans de Goede
Modified: 2011-06-15 10:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: spice-server-0.7.2-2.el6
Doc Type: Bug Fix
Doc Text:
Note to Content Author: I think this was not seen by users, but was part of developing spice-server and guest's vdagent. This bug adds a few fixes to the server, including: - Don't crash when a client disconnects while there are pending writes. - Always call read_from_vdi_port() in a while loop. This fixes a case where data read from the agent got lost. - Call read_from_vdi_port() from vdi_read_buf_release(). This fixes a possible case where spice-server fails to ever read more data from the agent on the guest as the port is throttled and stays throttled until the spice-server consumed all data from the current buffer.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-10-20 16:02:39 EDT
With the enabling of copy and paste support in RHEV-2.3, there will be a lot more data flowing through the vdagent channel. This means that we need to look at backporting the following upstream commits, which fix some issues in the server wrt vdagent channel data handling:
http://cgit.freedesktop.org/spice/spice/commit/?id=d37adccfa7e4586a68e7da8a225de0a50c6eeff5
http://cgit.freedesktop.org/spice/spice/commit/?id=a52324525d5707365c4b6758e5d5b08f21b0ac31
http://cgit.freedesktop.org/spice/spice/commit/?id=0b2336cd9c556cec98457e16e09e6c9855d81e82
Comment 4 Lubos Kocman 2011-04-11 13:29:01 EDT
Verified by code review of spice-server-0.8.0-1 patches seems to be implemented.
Comment 6 Uri Lublin 2011-05-09 03:41:15 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Note to Content Author: I think this was not seen by users, but was part of developing spice-server and guest's vdagent.

This bug adds a few fixes to the server, including:
- Don't crash when a client disconnects while there are pending writes.
- Always call read_from_vdi_port() in a while loop. This fixes a case where data read from the agent got lost.
- Call read_from_vdi_port() from vdi_read_buf_release(). This fixes a possible case where spice-server fails to ever read more data from the agent on the guest as the port is throttled and stays throttled until the spice-server consumed all data from the current buffer.
Comment 7 errata-xmlrpc 2011-05-19 10:07:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0705.html

Note You need to log in before you can comment on or make changes to this bug.