Bug 64510 - elinks crashes
Summary: elinks crashes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: elinks   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-06 22:46 UTC by Joshua Jensen
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-26 01:58:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2002-05-06 22:46:08 UTC
Description of Problem:

elinks crashes when I press Cntl-C

Version-Release number of selected component (if applicable):

stock 7.3

How Reproducible:

"links http://werwer.com", then press Ctrl-C immediately.  I see this:
                Memory leak by 23 bytes
                List of blocks: 0x8108cd0:47 @ dns.c:335
                Forcing core dump
                Segmentation fault

Please make it stop!  If I type the wrong URL, it is upsetting to see "core
dump" and "segmentation fault" when pressing Cntl-C.

Joshua

Comment 1 Leonid Mamtchenkov 2002-05-13 08:13:50 UTC
Hi,

This works for me too.  Here is what I get:
Memory leak by 19 bytes

List of blocks: 0x8111eb0:43 @ dns.c:335

Forcing core dump
Segmentation fault

-- 
 Best regards,
 Leonid Mamtchenkov


Comment 2 Need Real Name 2002-05-27 19:04:12 UTC
This should be fixed in upstream version 0.3.1.

http://archive.linuxfromscratch.org/mail-archives/links-list/2002/05/0134.html

Comment 3 Tim Waugh 2002-10-07 11:30:09 UTC
Fixed in elinks-0.3.2-1.


Note You need to log in before you can comment on or make changes to this bug.