Bug 64520 - Konqueror displays gobley-gook fonts on certain webpages.
Konqueror displays gobley-gook fonts on certain webpages.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-06 22:08 EDT by Ali-Reza Anghaie
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 15:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2002-05-06 22:08:34 EDT
Description of Problem: 
 
Konqueror/KHTML renders certain webpages with gobley-gook for the font. It seems to be 
KDE-wide as certain unidentifiable fonts in the drop-downs look like gobley-gook. And I 
can't seem to get rid of them. 
 
I've tried changing themes, fonts, etc. Played with a lot of possibilities and nothing 
came of it. Some pages this is readily evident (for me at least): 
 
http://espn.go.com/tennis/index.html 
http://www.sgi.com/products/ 
 
BTW, changing to Kmozilla fixes the problem but isn't preferable (obviously). 
 
 
Version-Release number of selected component (if applicable): 
 
 
kdebase-3.0.0-12 
 
How Reproducible: 
 
Always. 
 
 
Steps to Reproduce: 
1. Load Konq. 
2. Goto either of those two webpages above. 
3. Try in vain to find a fix. 
4. Hit Bugzilla. 
 
Actual Results: 
 
I see gobley-gook in a lot of areas on the page. 
 
Expected Results: 
 
I'd expect it to render properly. Just like Netscape, Moz, or Galeon.... 
Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-05-07 06:01:02 EDT
Not reproducable here; probably a setup problem. 
 
By any chance, do you permit xfs to use scaled bitmap fonts? 
 
If you have any of the following lines in /etc/X11/fs/config: 
catalogue = /usr/X11R6/lib/X11/fonts/misc, 
        /usr/X11R6/lib/X11/fonts/75dpi, 
        /usr/X11R6/lib/X11/fonts/100dpi, 
 
replacing them with the proper 
 
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled, 
        /usr/X11R6/lib/X11/fonts/75dpi:unscaled, 
        /usr/X11R6/lib/X11/fonts/100dpi:unscaled, 
 
should fix this problem.
Comment 2 Ali-Reza Anghaie 2002-05-07 09:21:30 EDT
Nope. I had unscaled on all those already. Since you pointed me in that
direction I asked a friend to send me a raw version of that file from a clean
Valhalla install. I had some other lines in there:

        /usr/share/fonts/ISO8859-7/misc:unscaled,
        /usr/share/fonts/ISO8859-7/75dpi:unscaled,
        /usr/share/fonts/ISO8859-7/100dpi:unscaled,
        /usr/share/fonts/ISO8859-7/misc,
        /usr/share/fonts/ISO8859-7/Type1,
        /usr/share/fonts/ISO8859-7/75dpi,
        /usr/share/fonts/ISO8859-7/100dpi,
        /usr/share/fonts/KOI8-R/100dpi:unscaled,
        /usr/share/fonts/KOI8-R/100dpi

That he didn't. So I backed up the file, replaced it with those lines removed.

And *poof*... problem dissapeared. I'm guessing this is NOTABUG but I'm trying
to figure out where those additional lines came from. My Valhalla install was
clean so the only thing I could suspect is OpenOffice maybe?

Anything else you want me to do? Regards, -Ali
Comment 3 Ali-Reza Anghaie 2002-05-07 10:15:20 EDT
This was the original config after the install: 
 
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled, 
        /usr/X11R6/lib/X11/fonts/75dpi:unscaled, 
        /usr/X11R6/lib/X11/fonts/100dpi:unscaled, 
        /usr/X11R6/lib/X11/fonts/misc, 
        /usr/X11R6/lib/X11/fonts/Type1, 
        /usr/X11R6/lib/X11/fonts/Speedo, 
        /usr/X11R6/lib/X11/fonts/cyrillic, 
        /usr/X11R6/lib/X11/fonts/CID, 
        /usr/X11R6/lib/X11/fonts/local, 
        /usr/X11R6/lib/X11/fonts/latin2/Type1, 
        /usr/X11R6/lib/X11/fonts/TTF, 
        /usr/share/fonts/default/TrueType, 
        /usr/share/fonts/default/Type1, 
        /usr/share/AbiSuite/fonts, 
        /usr/share/fonts/ja/TrueType, 
        /usr/share/fonts/ISO8859-7/misc:unscaled, 
        /usr/share/fonts/ISO8859-7/75dpi:unscaled, 
        /usr/share/fonts/ISO8859-7/100dpi:unscaled, 
        /usr/share/fonts/ISO8859-7/misc, 
        /usr/share/fonts/ISO8859-7/Type1, 
        /usr/share/fonts/ISO8859-7/75dpi, 
        /usr/share/fonts/ISO8859-7/100dpi, 
        /usr/share/fonts/KOI8-R/100dpi:unscaled, 
        /usr/share/fonts/KOI8-R/100dpi 
 
You'll notice duplicates for /usr/X11R6/lib/X11/fonts/misc , 
/usr/share/fonts/ISO8859-7/misc , and /usr/share/fonts/KOI8-R/100dpi .. 
 
One with 'unscaled' and the other without. 
 
As far as I can tell all of those fonts belong to RH. 
 
CCing Mike Harris upong his request. 
 
Regards, -Ali 
Comment 4 Ali-Reza Anghaie 2002-05-07 10:36:57 EDT
One last entry. I tried to remove the duplicates and leave all else the same. Still 
b0rked. So the only way I can get it to behave is by removing the ISO and KOI entries. 
 
My config as of now: 
 
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled, 
        /usr/X11R6/lib/X11/fonts/75dpi:unscaled, 
        /usr/X11R6/lib/X11/fonts/100dpi:unscaled, 
        /usr/X11R6/lib/X11/fonts/Type1, 
        /usr/X11R6/lib/X11/fonts/Speedo, 
        /usr/X11R6/lib/X11/fonts/cyrillic, 
        /usr/X11R6/lib/X11/fonts/CID, 
        /usr/X11R6/lib/X11/fonts/local, 
        /usr/X11R6/lib/X11/fonts/latin2/Type1, 
        /usr/X11R6/lib/X11/fonts/TTF, 
        /usr/share/fonts/default/TrueType, 
        /usr/share/fonts/default/Type1, 
        /usr/share/AbiSuite/fonts, 
        /usr/share/fonts/ja/TrueType 
 
I was thinking OpenOffice might have something to do with it as the config file's 
timestamp matched ~OO~ install. The thing is other folks clean Valhalla installs reflected 
my config file too. 
 
And the ISO and KOI fonts removed are all part of RH RPMs. I guess the RPMs will reveal 
all. 
 
Regards, -Ali 
 
CCing David Sainty too per his request.
Comment 5 Ali-Reza Anghaie 2002-09-30 22:58:46 EDT
Doesn't happen at all in 8.0. Cheers, -Ali

Note You need to log in before you can comment on or make changes to this bug.