Bug 645350 - User preferences in job search
Summary: User preferences in job search
Keywords:
Status: CLOSED DUPLICATE of bug 615469
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.6
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact:
URL:
Whiteboard: UX
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-21 11:30 UTC by Raymond Mancy
Modified: 2019-04-03 11:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-03 11:41:31 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2010-10-21 11:30:33 UTC
Enable users to set the result columns visible in their jobs page. Make these options in their preferences page

Comment 1 Raymond Mancy 2010-10-21 11:33:41 UTC
Created attachment 454797 [details]
some jobs page UI improvement

Comment 2 Bill Peck 2010-10-21 13:34:55 UTC
I like where you are going with this Ray!  Very nice.  

One question though, You show a system on the jobs page, what if there are multiple recipes for that job?  Which recipe is that system for?  

And was it intentional to put the jobid into the whiteboard?

Comment 3 Marian Ganisin 2010-10-22 07:43:32 UTC
(In reply to comment #2)
> One question though, You show a system on the jobs page, what if there are
> multiple recipes for that job?  Which recipe is that system for?

Attached screenshot is 'my job'. You hit the issue here. Fortunately for me personally this is not a problem so often, I am using 1 recipe per 1 job mostly, however some placeholder in form like '4 systems' is desirable.

Maybe also printing of all systems with <br> as separator could be used, but it will break nice output of slim rows. I wouldn't choose this way.

> And was it intentional to put the jobid into the whiteboard?

On the screenshot you can see I am using quite long whiteboards so I need to preserve the space. That's the reason why I put jobid into the whiteboard (and why I removed progress in '%' even if it is useful information).

Comment 4 Raymond Mancy 2010-11-03 01:29:47 UTC
Hi Guys, sorry I think I'm going to have to bump this to 0.5.62.
I've started thinking about a way to design this so we could have the user customise numerous things in various pages. Unfortunately though I don't think I'll be able to have it done for the coming release.

Comment 8 Tomas Klohna 🔧 2019-04-03 11:41:31 UTC
This request can be applied under #615469

*** This bug has been marked as a duplicate of bug 615469 ***


Note You need to log in before you can comment on or make changes to this bug.