Bug 64542 - rpm -iv --relocate
rpm -iv --relocate
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
www.urbanoexpress.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 14:35 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-07 16:13:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-07 14:35:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; T312461)

Description of problem:
#rpm -iv --relocate /opt/informix=/usr/informix IIF2K_920.UC1
Preparing packages for installation... IIF2K_920.UC1-1
Can't unlink /usrinformix-RPMDELETE: Is a directory error: unpacking of archive 
failed on file /usrinformix:
cpio: unlink failed -Is a directory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -iv --relocate /opt/informix=usr/informix IIF2K_920.UC1
2.
3.
	

Actual Results:  #rpm -iv --relocate /opt/informix=/usr/informix IIF2K_920.UC1
Preparing packages for installation... IIF2K_920.UC1-1
Can't inlink /usrinformix-RPMDELETE: Is a directory error: unpacking of archive 
failed on file /usrinformix:
cpio: unlink failed -Is a directory

Additional info:
Comment 1 Jeff Johnson 2002-05-07 14:43:19 EDT
Fixed since rpm-4.0.3-0.6. Try rpm-4.0.4 from
Raw Hide and/or errata.
Comment 2 Jeff Johnson 2002-05-09 12:18:59 EDT
Why was this reopened?

Note You need to log in before you can comment on or make changes to this bug.