Bug 64543 - Cannot install / run vmware GSX server on skipjack beta 2
Cannot install / run vmware GSX server on skipjack beta 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 14:41 EDT by Tom Warfel
Modified: 2016-11-24 07:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 10:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 64543 master MERGED storage: GenerationMismatch exception 2016-09-29 17:29 EDT

  None (edit)
Description Tom Warfel 2002-05-07 14:41:34 EDT
Description of Problem:
Running /usr/bin/vmware gives the error message:
/usr/bin/vmware: relocation error: /usr/bin/vmware: undefined symbol: atexit
/usr/bin/vmware: relocation error: /usr/bin/vmware: undefined symbol: atexit

and dies.  I suspect a library (most likely glibc or libc_something) 
somewhere lacks a necessary component (atexit) it once had.  As a result, 
a key application will not execute.  This happens both with the 
current release build as well as the new GSX Server Beta.

Version-Release number of selected component (if applicable):
glibc-2.2.5-32 (I think this is the culprit)

How Reproducible:
Every time.

Steps to Reproduce:
1. Go to the vmware web site (www.VMware.com) and apply for / receive a 30-day
evaluation license.
2. Download either the current or Beta GSX server 2.0
3. Try to run vmware-config.pl.  When it gets to running /usr/bin/vmware
it gives the error message about "atexit" not being found.

Actual Results:
dies.

Expected Results:
works.  Both release and Beta work fine under 

Additional Information:
Not sure how to best proceed from here.  I sent a note to VMware, but was told
"since it works on 7.2 (which it does), and doesn't on Skipjack, the problem
is with skipjack."  This needs to be fixed before the main release, as we 
depend on VMware GSX server to provide multiple virtual windows services.
Comment 1 Jakub Jelinek 2002-05-10 10:19:31 EDT
This was fixed in Valhalla glibc.

Note You need to log in before you can comment on or make changes to this bug.