Bug 645774 - Feature Request for ability to modify a version of a bundle.
Feature Request for ability to modify a version of a bundle.
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
3.0.0
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 08:54 EDT by dsteigne
Modified: 2014-06-27 19:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-27 17:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2010-10-22 08:54:44 EDT
Description of problem:
Requesting the ability to modify an existing bundle version instead of deploying a new version.

Version-Release number of selected component (if applicable):
2.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Mazzitelli 2010-12-13 13:47:03 EST
what do you want to edit?

IIRC, bundle versions are required to be static. If we allow a bundle version to be altered (such as its content) then those groups who previously had that bundle deployed will be "out of date". We'll think they have the new content (since that's what's in the bundle version after the change) but it really has the old content. This would be bad for auditing purposes among other reasons (another is the metadata about the version is out out of date on the agent's .rhqdeployments directory). We'd have to do some interesting things like "if you change a bundle version, go to all the groups where this is deployed and update those bundles". Which would be complicated to do - whereas you just creating a new bundle version and deploying that would do the same.

But I guess to get a better feel for what is being requested, I have to ask what it is that you want to change?
Comment 2 dsteigne 2014-06-09 07:59:40 EDT
For example, I have version 1.0 of my bundle but realize that I want to change something in it but I still want the version to be 1.0.
Comment 3 Jay Shaughnessy 2014-06-27 17:19:33 EDT
This is not possible,  You'd have to delete the existing bundle version and re-upload the updated bundle version. In general this is not a great idea because if the bundle version has been deployed, the agent-side has already operated on the bundle version as-it-was.  So it could mess things up to change the bundle version, especially in a revert scenario.  Recommend to just increment the version if it really changes.
Comment 4 John Mazzitelli 2014-06-27 19:13:25 EDT
(In reply to dsteigne from comment #2)
> For example, I have version 1.0 of my bundle but realize that I want to
> change something in it but I still want the version to be 1.0.

I agree with Jay. That would be very bad. If you change something, its no longer 1.0.

Note You need to log in before you can comment on or make changes to this bug.