Bug 64590 - od "-t f8 --width 8" insists on width = 12
od "-t f8 --width 8" insists on width = 12
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-05-08 09:04 EDT by Tony Kocurko
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-25 22:03:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tony Kocurko 2002-05-08 09:04:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
Either "-t f8" or "--format=f8" used with the "od" command results in
od claiming that the format size is invalid and insists on using 12
bytes per double rather than 8.

Solved. Change lines 137 and 138 of od.c from this:

sizeof (long int),
sizeof (float),

to this:

sizeof (long int),
sizeof (long long),
sizeof (float),

  I have already sent this problem and its solution along to

Tony Kocurko
Memorial University of Newfoundland
Department of Earth Sciences
Alexander Murray Building - Room ER-4063
Memorial University of Newfoundland
St. John's, Newfoundland
Canada     A1B 3X5

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. od -t f8 --width 8 any_file_at_all 2>&1 | more
2. Look for "warning: invalid width 8; using 12 instead"

Actual Results:  See step 2., above. Also, the address-radix increment is
instead of 8.

Expected Results:  Doubles should have been dumped.

Additional info:

The bug is solved with the fix mentioned above.
Comment 1 Tim Waugh 2002-10-07 07:32:28 EDT
Seems to be fixed in textutils-2.0.21-5.

Note You need to log in before you can comment on or make changes to this bug.