Bug 64599 - Bad error reporting in anaconda
Bad error reporting in anaconda
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
http://student.cs.ucc.ie/~cjvdb1/imag...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 10:56 EDT by cjvdb1
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 23:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cjvdb1 2002-05-08 10:56:26 EDT
Description of Problem:
Installing redhat 7.3. Get error message as per 
http://student.cs.ucc.ie/~cjvdb1/images/rh73inst/p5070292.jpg saying disk is 
probably full. According to df in 
http://student.cs.ucc.ie/~cjvdb1/images/rh73inst/p5070292.jpg disk has many 
gigabytes still free.
This mystified me at first, but I have since discovered that the real error 
would appear to be a read error on the cd (another copy of the CD installs 
fine).

Version-Release number of selected component (if applicable):
Don't know. The one on valhalla-i386-disc1.iso :)

How Reproducible:
Every time, with particular CD.

Steps to Reproduce:
1. Boot from CD containing package with read error (in this case, 
openjade-1.3.1-4 )
2. Proceed with upgrade install.
3. Install falls over when it gets to unreadable package.

Actual Results:
Install fails because of one unreadable package, and gives inappropriate error 
message (disk probably full).

Expected Results:
Successful install, skipping unreadable package.

Additional Information:
See http://student.cs.ucc.ie/~cjvdb1/images/rh73inst/anacdump.txt and images 
in that directory.
Comment 1 Bruce Littlefield 2002-05-08 13:12:53 EDT
Another traceback for a similar problem (no disk full error message, just a
crash with traceback) is available from
http://www.eece.maine.edu/~brucel/anacdump.txt
Comment 2 Charles R. Tersteeg 2002-05-08 23:38:20 EDT
i checked all my cds - 1 said it passed the test - the other two failed.  all
iso images matched the check sum.  most i can figure is that it is a bad burn. 
i used xcdroast from the beta 2 version.  this is bug 64599 seems to be a dupe
of 64539.

workaround i copied all the files to one dir and did a http install, worked fine.
Comment 3 Michael Fulbright 2002-05-09 14:27:29 EDT
It is recommended you use the mediacheck option at boot time to catch the CD
coaster problem.
Comment 4 cjvdb1 2002-05-10 06:11:14 EDT
It's an imperfect world; coasters exist. I would imagine read errors are one 
of the most common errors during an install - why not report them properly? 
"You are probably out of disk space" is very misleading. Other OS installers 
give various options in this situation (abort/retry/fail ring any bells?); why 
does RedHat only offer abort/debug? (where debug also leads to abort)
Comment 5 Bruce Littlefield 2002-05-10 10:39:04 EDT
MY CDs are fine. The problem seems to be that the openjade rpm package causes
the failure. The upgrade installation expects the openjade rpm on CD#1, but it
is packaged on CD#2. When the package is not found, the installer aborts. If all
rpms are in the same directory (disk, ftp, or http install) or openjade is not
one of the packages to be installed, the problem does not exist. See the
anacdump.txt files in the URLs above.
Comment 6 Jay R. Ashworth, http://baylink.pitas.com 2002-10-06 22:26:55 EDT
I concur with cjvdb1 -- the problem here isn't that the install crashes, it's
the Microsoft-quality error message that's given, and the fact that the error
isn't trapped.

I propose to file a new bug with this adjusted description, if no one sees fit
to reopen one of the currently extant ones, and I will *not* tolerate a NOTABUG
on it.

Note You need to log in before you can comment on or make changes to this bug.