Bug 64611 - incomplete rpm dependencies
incomplete rpm dependencies
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 12:24 EDT by Mikko Tiihonen
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 15:31:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikko Tiihonen 2002-05-08 12:24:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
When running up2date without the db1-1.85-8.i386.rpm installed fails even though
the upd2date rpm does not depend on db1.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -e db1
2. up2date


Actual Results:  Traceback (innermost last):
  File "/usr/sbin/up2date", line 1169, in ?
    main()
  File "/usr/sbin/up2date", line 415, in main
    from up2date_client import gui
  File "/usr/share/rhn/up2date_client/gui.py", line 20, in ?
    import gnome, gnome.ui
  File "/usr/lib/python1.5/site-packages/gnome/ui.py", line 3, in ?
    import _gnomeui, gnome
ImportError: libdb.so.2: cannot open shared object file: No such file or directory


Expected Results:  the up2date should have started

Additional info:

The problem goes away when after installing the db1-1.85-8.i386.rpm.
Comment 1 Adrian Likins 2002-05-08 15:31:06 EDT
Looks like gnome is missing the dep actually, since no gnome
apps work when you do that. 

I'm reassinging this to a gnome component.
Comment 2 Havoc Pennington 2002-07-06 18:40:03 EDT
db1 is in the gnome-libs package now, so it'd be hard to remove it.

Note You need to log in before you can comment on or make changes to this bug.