Bug 64620 - hard lockup under load
hard lockup under load
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 14:07 EDT by Dan Berger
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 14:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of crash w/ "options cs46xx cs_debuglevel=9 cs_debugmask=0xffff" (29.07 KB, text/plain)
2002-05-08 14:52 EDT, Dan Berger
no flags Details

  None (edit)
Description Dan Berger 2002-05-08 14:07:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
Hardware Configuration:
1.3Ghz Athlon, 
512Meg RAM, 
ABIT KT7A (Via KT133A chipset), 
Nvidia GeForce 2MX,
Hercules Gamesurround Fortissimo II Audio Card (Cirrus Logic SoundFusion CS4624
chipset)

Software Configuration:
RedHat 7.2 w/ Updates
2.4.18-3 kernel (from RedHat 7.3, with required dev and iptables packages)
XFree 4.1.0
VMWare 2.0.4
Nvidia driver 1.0-2880

I've used both alsa 0.9 rc1 and the "native" OSS drivers - the symptoms are
identical in each.

The symptom is that during audio playback under high sustained CPU load the
machine freezes - typically, but not always, with audio looping.  

I've eliminated both X and the nvidia driver by bringing the machine up in init
level 3 and insuring the NVdriver module never loads.

I've eliminated the vmware modules as culprits similarly (insuring that from
power off, they are never loaded).

I've tried the following kernel options with no success:

mem=nopentium
apm=off
noapic

When the machine locks up, it does not respond to Alt-SysReq. 

It's 100% reproducable - in one window (or console) - start audio playback (I've
been using ogg123 as the test driver since I have a large collection of ogg
files) and in another start a compile (my test has been compiling
freeamp-2.1.1).  After approx 10 seconds, observe the lockup, power cycle the
machine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. in one window (or console) - start audio playback (I've been using ogg123 as
the test driver since I have a large collection of ogg files)
2. in another start a compile (my test has been compiling freeamp-2.1.1).
3. After approx 10 seconds, observe the lockup, power cycle the machine.
	

Additional info:
Comment 1 Dan Berger 2002-05-08 14:11:53 EDT
BTW: per the MAINTAINERS file, I've also email Alan (Cox), Nils Faerber, and
Jaroslav Kysela (of the ALSA project, on who's code this driver was based)
Comment 2 Dan Berger 2002-05-08 14:12:53 EDT
Oh, and I suppose I should have noted that the reason I'm running the 2.4.18
kernel is because I was hoping it would fix the problem when I discovered it
under teh 2.4.9-21 kernel.
Comment 3 Dan Berger 2002-05-08 14:52:41 EDT
Created attachment 56707 [details]
log of crash w/ "options cs46xx cs_debuglevel=9 cs_debugmask=0xffff"
Comment 4 Dan Berger 2002-05-08 15:41:37 EDT
Gents - at this point I think I may be chassing my tail, and I don't want anyone
else wasting any time until I'm sure.  I can reliably cause the machine to lock
under load without the sound driver loaded - which either means it's a kernel
bug or (more likely) an issue with my machine.

To cause the lockup without involving sound requires a higher load than with,
but it locks just as reliably.  (make -j 16 will do it every time with out
involving the sound driver). 

Until I get some supporting data, consider this a non-bug.
Comment 5 Julien Olivier 2003-11-27 12:55:58 EST
Hi

Could you tell me if those 2 bug reports might be related to this one ?

 -> Bug #102961
 -> Bug #127814

Thanks !

Note You need to log in before you can comment on or make changes to this bug.