Bug 64634 - gnome panel has trouble remembering applets
Summary: gnome panel has trouble remembering applets
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-08 21:40 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 00:43:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2002-05-08 21:40:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020501

Description of problem:
I add an applet to the bar and it works. Then I restart X and there is a icon of
the gnome foot with a black background in the place of the last added applet. It
acts like an applet but all it lets you do is remove, aka a dummy applet. If I
add more than one per X session each new applet will be replaced by a dummy
applet. I tried checking ~/.gnome/panel.d/default/Applet_Config and the entry
for a new applet seems to be valid, but of course doesn't work. If I edit the
end of Applet_Config like below before restarting X then the applet works fine,
even after multiple restarts.

[Applet_9]
id=Extern
goad_id=glms_applet
position=594
panel=0
unique_panel_id=10000001
right_stick=true

[Applet_10]
id=Empty

to

[Applet_9]
id=Extern
goad_id=gtele_applet
position=594
panel=0
unique_panel_id=10000001
right_stick=true

[Applet_10]
id=Extern
goad_id=glms_applet
position=753
panel=0
unique_panel_id=10000001
right_stick=true

Where glms was the added applet, but was set to empty after the panel failed to
load it and put a dummy applet in it's place.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start X
2. Load eight applets
3. Restart X
4. Load 2 more applets
5. Restart X


	

Actual Results:  Dummy applets in the place of newly added applets

Expected Results:  All applets to load correctly every time.

Additional info:

The reporudcibility seems to be related to how many applets are added. I started
noticing a problem around 8 applets.

Comment 1 Havoc Pennington 2002-05-08 22:10:24 UTC
Not a nice bug. :-( Thanks for the report, will investigate.

Comment 2 Nathan G. Grennan 2002-05-23 00:43:03 UTC
I tried going back to the gnome-core from RedHat 7.2 to see if that helped. It
didn't seem to at all. Which to me would point at a bug in a library that it is
dependent on.

Comment 3 Nathan G. Grennan 2002-05-23 03:17:59 UTC
I finally got frustrated enough with this problem and fussed with it for a few
hours. The end result, it is a misbehaving applet I am using that doesn't come
from RedHat. So now I need to track down the bug in it. Plus now that I know it
is that applet, it is easy to workaround.


Note You need to log in before you can comment on or make changes to this bug.