Bug 64639 - Unable to turn on DMA on ide hard drives on Tyan 2720
Summary: Unable to turn on DMA on ide hard drives on Tyan 2720
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-08 22:58 UTC by Samuel Flory
Modified: 2007-04-18 16:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:09:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Samuel Flory 2002-05-08 22:58:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020427

Description of problem:
  Under your 2.4.9-31 kernel and well as the main line 2.4.18 you can turn on
dma on the Tyan 2720.  You can't do this on 2.4.18-3.  The result is that hard
drive access is very slow.

[root@localhost root]# hdparm -d /dev/hda

/dev/hda:
 using_dma    =  0 (off)
[root@localhost root]# hdparm -d 1 /dev/hda

/dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install tyan 2720 system
2.hdparm -d 1 /dev/(drive)
	

Actual Results:  /dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)

Expected Results:  /dev/hda:
 setting using_dma to 1 (on)
 using_dma    =  1 (on)


Additional info:

  I suspect this issue is due the the ide code you guys imported from the ac kernel.

Comment 1 Seth Bardash 2002-05-30 00:03:15 UTC
I have exactly the same problem. Can't get the Tyan S2720GN to turn on DMA 
on /dev/hda when I type: hdparm -d1 /dev/hda. System config is Dual 2.2G Xeons, 
1GB Memory, RH 7.3 with latest updates (Kernel 2.4.18-4smp)

Top disk I/O Speed is 6+ MB/sec to a 40 GB IBM 7200 RPM ATA-100 disk. This s/b 
closer to 20MB/sec or better.

There is a patch: ide-2.4.19-p7.all.convert.10.patch.bz2 at 
http://www.linuxdiskcert.org/ but since this is not the same kernel I don't 
think its appropriate. Any help would be appreciated. 

seth@integratedsolutions.org

Is there a patch on the way or an rpm update for 2.4.18-4smp???

Comment 2 Roderick Constance 2002-06-25 00:41:33 UTC
Try Tyan's new beta BIOS: 2720529a.  I've successfully been able to use DMA with
this motherboard and 2.4.18-4smp.

http://www.tyan.com/support/html/bios_support.html#beta

Comment 3 Need Real Name 2002-10-14 18:20:09 UTC
Check for:

1) If you have "USE_DMA = 1" set either in "/etc/sysconfig/harddisks" or 
in "/etc/sysconfig/harddisk[IDE_DEVICE_NODE]", where IDE_DEVICE_NODE is "hda, 
hdb, hdc .... etc"

2) If you have options line for "ide-cd" in  "/etc/modules.conf" reading as:

options ide-cd dma=1

above to changes worked for me....

good luck!

Comment 4 Arjan van de Ven 2003-06-07 19:09:34 UTC
current erratum kernel ought to have this fixed


Note You need to log in before you can comment on or make changes to this bug.