Bug 64641 - /usr/include/asm/msr.h gone missing...
/usr/include/asm/msr.h gone missing...
Status: CLOSED DUPLICATE of bug 86244
Product: Red Hat Linux
Classification: Retired
Component: glibc-kernheaders (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-05-08 19:03 EDT by adler
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:48:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description adler 2002-05-08 19:03:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
/usr/include/asm/msr.h is not in glibc-kernheaders-2.4-7.14

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.do an ls of "/usr/include/asm/msr.h"
2.not there...

Additional info:

My guess is that when you guys moved the kernel-header stuff over to
glibc-kernheaders, you forgot to include asm/msr.h.
Comment 1 Michael Schwendt 2002-05-09 17:44:47 EDT
Likely related to bug #64647.
Comment 2 Arjan van de Ven 2002-05-20 04:54:15 EDT
msr.h is a kernel internal header with absolutely no stable API properties....
Including it in the glibc header set would not be a good idea.
(Not to mention that it includes GPL inline functions)
Comment 3 adler 2002-05-20 10:05:23 EDT
The reason I came across this, was becuase I was including a file
/usr/include/asm/timex.h which in turn includes /usr/include/asm/msr.h. So maybe
the definition of the bug should change to, "compiler bombs when including
/usr/include/asm/timex.h becuase it cannot find the file /usr/include/asm/msr.h".

Comment 4 James Olin Oden 2002-07-18 14:17:26 EDT
The purpose of the kernrel headers as I understand them are to provide the 
"kernel headers" for a particular release of the kernel (preferably the kernel
on your system).  So even if this file may have certain questioinable qualities
if it is part of the kernel headers then it should be in the glibc-kernheaders.

Comment 5 Arjan van de Ven 2002-07-18 18:31:03 EDT
Ehm no. The kernel headers are for the INTERNAL kernel code to compile against.
The GLIBC headers (glibc-kernheaders package) describe the userspace<->kernel
interface, and nothing more.
Comment 6 Bill Nottingham 2003-10-02 11:20:25 EDT

*** This bug has been marked as a duplicate of 86244 ***
Comment 7 Ra P. 2005-12-14 01:42:35 EST
<i>msr.h is a kernel internal header with absolutely no stable API properties</i>

This is complete bullshit.  It contains a bit of inline assembly and a bunch of #defines.  Nothing in there is 
Linux specific, and this idiotic decision basically makes it impossible to access the TSC and other MSRs 
from user space.

Thanks Red Hat!
Comment 8 Red Hat Bugzilla 2006-02-21 13:48:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.