Bug 64646 - libpng / kde* inconsistency
libpng / kde* inconsistency
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libpng (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 21:17 EDT by Stanislav Kutil
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 21:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Kutil 2002-05-08 21:17:35 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-9; Linux) 
 
Description of problem: 
Lots of latest kde* components require libpng.so.3 which is included in 
libpng package, but it isn't in 'provides' list of libpng-1.2.2-4. Which makes 
upgrading without --nodeps impossible. Another problem is in gcc2.96 style 
sonames in e.g. kdebase. They are required but they are not provided in 
any currently available package. Rebuild against gcc3 in all kde 
components should help. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
Just try to install the latest kde packages. 
rpm -U libpng-1.2.2-4.i386.rpm kdebase-3.0.0-12.i386.rpm 
kdelibs-3.0.0-11.i386.rpm 
 
 
Actual Results:  error: failed dependencies: 
        libDCOP-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkabc-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libkatepartinterfaces-gcc2.96.so   je nutni pro kdebase-3.0.0-12 
        libkdecore-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkdefx-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkdeprint-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkdeprint_management-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkdesu-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkdeui-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkhtml-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkio-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkjava-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libkparts-gcc2.96.so.2   je nutni pro kdebase-3.0.0-12 
        libkscreensaver-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libkscript-gcc2.96.so   je nutni pro kdebase-3.0.0-12 
        libktexteditor-gcc2.96.so   je nutni pro kdebase-3.0.0-12 
        libvcard-gcc2.96.so   je nutni pro kdebase-3.0.0-12 
        libartsflow-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libartsflow_idl-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libartskde-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libkdesasl-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libkmedia2_idl-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libkmid-gcc2.96.so.0   je nutni pro kdebase-3.0.0-12 
        libkspell-gcc2.96.so.4   je nutni pro kdebase-3.0.0-12 
        libmcop-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libqtmcop-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libsoundserver_idl-gcc2.96.so.1   je nutni pro kdebase-3.0.0-12 
        libpng.so.3   je nutni pro kdelibs-3.0.0-11 
        kdebase = 3.0.0-9 je nutni pro kdebase-devel-3.0.0-9 
 
 
Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-05-16 11:20:12 EDT
This is because not all KDE packages have been rebuilt in the rawhide 
environment yet - Now that 3.0.1 is in the tree, this should be fixed (with 
the exception of kdeadmin, which doesn't compile ATM because of rpmlib API 
changes). 
Comment 2 Jonathan Blandford 2003-02-19 22:44:17 EST
*** Bug 67007 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.