Bug 64653 - After an update from 7.2 installation mozilla dies with SIGSEGV
Summary: After an update from 7.2 installation mozilla dies with SIGSEGV
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 64655 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-09 04:33 UTC by Michal Jaegermann
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 16:26:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A trace from a failed attempt to start mozilla (67.75 KB, application/x-gzip)
2002-05-09 04:35 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2002-05-09 04:33:46 UTC
Description of Problem:

After an update from 7.2 installation Mozilla bombs out on every attempt
of a startup.  Attached strace seems to point to a missing
/usr/lib/mozilla/components/libtimer_gtk.so which is nowhere to be found.
Possibly this is not a reason (see below).

Luckily Netscape still works as I would have problems to file that report
(galeon is also adversly affected).

Version-Release number of selected component (if applicable):
mozilla-0.9.9-7

How Reproducible:
every time

Additional Information:
	
These are all mozilla packages which were installed by an update:

mozilla-0.9.9-7
mozilla-nspr-0.9.9-7
mozilla-nss-0.9.9-7

A Skipjack "from scratch" test installation does not show this problem
despite the fact that 'libtimer_gtk.so' also missing there but a list
of mozilla packages installed there is far more extensive:

mozilla-0.9.9-5.i386.rpm
mozilla-chat-0.9.9-5.i386.rpm
mozilla-devel-0.9.9-5.i386.rpm
mozilla-dom-inspector-0.9.9-5.i386.rpm
mozilla-js-debugger-0.9.9-5.i386.rpm
mozilla-mail-0.9.9-5.i386.rpm
mozilla-nspr-0.9.9-5.i386.rpm
mozilla-nspr-devel-0.9.9-5.i386.rpm
mozilla-nss-0.9.9-5.i386.rpm
mozilla-nss-devel-0.9.9-5.i386.rpm
mozilla-psm-0.9.9-5.i386.rpm

and things are still ok after replacing these with 0.9.9-7 versions.

Comment 1 Michal Jaegermann 2002-05-09 04:35:02 UTC
Created attachment 56765 [details]
A trace from a failed attempt to start mozilla

Comment 2 Michal Jaegermann 2002-05-09 21:50:30 UTC
Rerunning /usr/lib/mozilla/mozilla-rebuild-databases.pl, on an advice
of Christopher, appears to solve the issue on the first look.  Apparently
something forgot to do that in an upgrade process.

Comment 3 Christopher Blizzard 2002-05-09 21:51:59 UTC
Did you happen to have only the mozilla package installed?  (no mail or psm?)

Comment 4 Christopher Blizzard 2002-05-09 21:58:39 UTC
*** Bug 64655 has been marked as a duplicate of this bug. ***

Comment 5 Michal Jaegermann 2002-05-09 22:54:25 UTC
I did not add any packages to mine "main" installation.  They are the same
as originally reported. OTOH I did not use 'mozilla' very much.  Usually
'galeon' for me is more then enough. :-)  But I did check that it does retrieve
few various sites.

I am typing this right now using 'galeon' in question. :-)

Comment 6 Christopher Blizzard 2002-05-09 23:50:11 UTC
What does rpm -qa|grep ^mozilla" give you?

Comment 7 Michal Jaegermann 2002-05-09 23:55:36 UTC
:-)
$ rpm -qa | grep '^moz'
mozilla-0.9.9-7
mozilla-nss-0.9.9-7
mozilla-nspr-0.9.9-7


Comment 8 Christopher Blizzard 2002-05-10 00:00:47 UTC
Yeah, I'll bet that was caused by a bug I just fixed in the rpm spec file.

Comment 9 Peter Englmaier 2002-05-13 16:25:56 UTC
Hi, I had the same problem and fixed it with the command
/usr/lib/mozilla/mozilla-rebuild-databases.pl
given above. I only had/have two packages installed:
mozilla-nspr-0.9.9-7
mozilla-0.9.9-7
Have fun!
Peter.



Comment 10 Christopher Blizzard 2002-08-29 22:27:38 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.