Bug 646533 - eds crashes on exchange_account_rescan_tree/g_hash_table_foreach [NEEDINFO]
eds crashes on exchange_account_rescan_tree/g_hash_table_foreach
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks: 569781
  Show dependency treegraph
 
Reported: 2010-10-25 11:37 EDT by ritz
Modified: 2014-06-02 09:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:25:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pm-rhel: needinfo? (rkhadgar)


Attachments (Terms of Use)
patch based on upstream code (10.23 KB, patch)
2010-10-25 11:37 EDT, ritz
no flags Details | Diff
patch based on upstream code (10.23 KB, patch)
2010-10-25 11:51 EDT, ritz
no flags Details | Diff

  None (edit)
Description ritz 2010-10-25 11:37:03 EDT
Created attachment 455561 [details]
patch based on upstream code

Description of problem:
eds crashes on exchange_account_rescan_tree/g_hash_table_foreach

Version-Release number of selected component (if applicable):
eds 1.12.3-18.el5

How reproducible:
frequent

Steps to Reproduce:
1. Enable auto-complete with MS exchange/GAL
  
Actual results:
Crash

Expected results:
No crash

Additional info:
bt follows 

#8  <signal handler called>
#9  0x0011f557 in g_hash_table_foreach () from /lib/libglib-2.0.so.0
#10 0x024b0752 in exchange_account_rescan_tree (account=0x896cd68)
    at exchange-account.c:325
#11 0x0806df20 in e_book_backend_exchange_start_book_view (backend=0x89ca7c0, 
    book_view=0xb7213b20) at e-book-backend-exchange.c:1993
#12 0x06db4fb2 in e_book_backend_start_book_view (backend=0x89ca7c0, 
    book_view=0xb7213b20) at e-book-backend.c:305
#13 0x06db69fb in impl_GNOME_Evolution_Addressbook_BookView_start (
    servant=0xb7213b34, ev=0xb67fe278) at e-data-book-view.c:492
#14 0x06da9a86 in _ORBIT_skel_small_GNOME_Evolution_Addressbook_BookView_start
    (_o_servant=0xb7213b34, _o_retval=0x0, _o_args=0x0, _o_ctx=0xb67fe1a8, 
    _o_ev=0xb67fe278, 
    _impl_start=0x6db69b0 <impl_GNOME_Evolution_Addressbook_BookView_start>)
    at Evolution-DataServer-Addressbook-common.c:36
#15 0x07b5d657 in ?? () from /usr/lib/libORBit-2.so.0


patch based on
commit e90741e30054316ef69a7e387b636727f24e65e0
Author: Milan Crha <mcrha@redhat.com>
Date:   Thu Aug 14 12:45:35 2008 +0000

    ** Fix for bug #337503

commit 3d8776dfbd00ed300d804a93cd8e655e25921f5e
Author: Milan Crha <mcrha@redhat.com>
Date:   Tue Apr 29 07:51:02 2008 +0000

    ** Fix for bug #502899
Comment 1 ritz 2010-10-25 11:51:58 EDT
Created attachment 455564 [details]
patch based on upstream code

fixed a typo ( missing semi-colon )
Comment 2 RHEL Product and Program Management 2011-05-31 11:07:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2014-03-07 08:57:44 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:25:57 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.