Bug 64654 - Usability Testing of anaconda Needed
Usability Testing of anaconda Needed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 00:42 EDT by Bob Cochran
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-07 14:53:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Cochran 2002-05-09 00:42:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
The anaconda installer is "slanted" towards people with strong unix or Linux
backgrounds, causing an unnecessarily difficult installation experience for the
new user. This in turn is hurting acceptance of the Red Hat Linux product,
branding it as something for deep Unix hackers only. Please consider doing
usability testing of the anaconda installer with the help of ordinary users --
not people with significant unix or Linux experience, but off the street,
ordinary users. Especially ask help from new users such as young students, blue
collar workers, secretaries, and business people not in the information
technology career sector.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The installer has a tendency to expect the user to be deeply knowledgable about
the hardware of the system on which Red Hat Linux will be installed.Few ordinary
users would have such knowledge. For example, few users actually know their
monitor refresh frequencies. My wife and brother-in-law don't and both hold
earned Ph.D degrees. Nor  do they or other highly skilled professionals have the
time to waste on finding out this useless bit of information. 
	

Actual Results:  The installation experience could easily be greatly delayed or
dropped because the installer program asks far too much technical information of
the user. I've given one friend of mine Red Hat CDs and documentation for a few
years now and I think he is scared off from installing for this very reason. 

Expected Results:  Red Hat needs to conduct extensive usability testing of the
anaconda installer aimed at reducing the amount of user interaction needed for a
successful installation to occur. Listen to what ordinary people have to say,
and change the installer to accomodate them. For example: anaconda should "know"
the optimal refresh frequencies for my monitor. Consulting a database on the
internet or on CD should be no big deal. Ideally, the entire installation should
take place with NO user intervention other than flipping CDs in and out of the
drive. Specialized user knowledge should not be required in any case. 

Additional info:
Comment 1 Michael Fulbright 2002-05-09 14:23:06 EDT
No argument some improvements could be made.  However since this bug report has
no particular instances or suggestions I can't really use it in its current form.

Can you please submit bug reports with particular UI changes you think would be
helpful?  

We know the installer is aimed at a technical user, but that is because that is
our market.  Until our product marketing people come out with a 'newbie' linux
product we do not have the resources to apply in that area.  Our current focus
is on enterprise customers.  We have some ideas we try to add occasionally to
make it easier for newbies, but its in our spare time.
Comment 2 Michael Fulbright 2003-03-07 14:53:03 EST
We have been making improvements since this report.  There are no particular
examples to address as far as I see.

Note You need to log in before you can comment on or make changes to this bug.