Bug 64655 - After an update from RH 7.2 galeon does not display anything
After an update from RH 7.2 galeon does not display anything
Status: CLOSED DUPLICATE of bug 64653
Product: Red Hat Linux
Classification: Retired
Component: galeon (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 00:50 EDT by Michal Jaegermann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-09 17:51:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a trace from an attempt to start a galeon browser (118.80 KB, application/x-gzip)
2002-05-09 00:51 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2002-05-09 00:50:09 EDT
Description of Problem:

On an installation updated from Red Hat 7.2 galeon starts but its main
window remains blank with any URL which is tried.  After starting it
from a terminal window mulitiple (over 10) messages like this:

**************************************************
nsNativeComponentLoader: GetFactory(/usr/lib/mozilla/components/libtimer_gtk.so) 
Load FAILED with error: /usr/lib/mozilla/components/libtimer_gtk.so: cannot open 
shared object file: No such file or directory
**************************************************

show up.  At least picking "Exit" or "Close" from a menu give back a shell
prompt.

This situation is different on attempts to strace (a sample attached).
After hitting "Exit" on straced galeon menu this does not return to
a shell prompt. 'ps' shows "[galeon-bin <defunct>]" in a state "Z"
and some other, parent, galeon-bin processes in states "T" and "S".
Only after few 'killall -9 galeon-bin', as 'killall galeon-bin' does
not has any visible effect one can see:

Process 1672 detached
Unable to wait on inferior: No child processes

and prompt returns.

Version-Release number of selected component (if applicable):

galeon-1.2.0-7

How Reproducible:
every time


Additional Information:
Temporary removal of ~/.galeon, ~/.gnome and similar does not seem to
provide any help.  This is a pain and forces me to use Netscape again.

Galeon from a test "from scratch", instead of an update, installation of 
Skipjack does not exhibit anything of that kind but in my "real" installation
my data are much more important then a supporting software and redoing it
with every release is not a viable proposition.
Comment 1 Michal Jaegermann 2002-05-09 00:51:18 EDT
Created attachment 56784 [details]
a trace from an attempt to start a galeon browser
Comment 2 Michal Jaegermann 2002-05-09 17:51:41 EDT
The same remark about /usr/lib/mozilla/mozilla-rebuild-databases.pl as in
64653 seems to apply here as well.
Comment 3 Christopher Blizzard 2002-05-09 17:58:43 EDT

*** This bug has been marked as a duplicate of 64653 ***

Note You need to log in before you can comment on or make changes to this bug.