Bug 64683 - Builtin signal names wrong in psmisc (killall)
Builtin signal names wrong in psmisc (killall)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: psmisc (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
: 67115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 12:05 EDT by Trond Eivind Glomsrxd
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-26 01:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch 20.2 back the correct signals from 20.1 (759 bytes, patch)
2002-05-15 03:43 EDT, J. Nick Koston
no flags Details | Diff

  None (edit)
Description Trond Eivind Glomsrxd 2002-05-09 12:05:49 EDT
The signal name-> number wrapping is wrong. I.e. doing a "killall -CONT foo"
will send SIGSTOP. Many others are wrong too...

psmisc-20.2-3 has a correct list for i386, but it should be autogenerated (it
might differ by arch). An errata should be strongly considered.
Comment 1 J. Nick Koston 2002-05-15 03:43:31 EDT
Created attachment 57364 [details]
Patch 20.2 back the correct signals from 20.1
Comment 2 J. Nick Koston 2002-05-15 03:45:17 EDT
This should be considered much more critical as SIGUSR1 will send SIGPWR.  This
is really bad when mixed will 'killall -USR1 httpd'  since apache will die
instead of do a graceful restart.  

Patched RPMS here: http://diff.cpanel.net/pub/sysup/7.3/psmisc/
Comment 3 Trond Eivind Glomsrxd 2002-05-15 11:25:08 EDT
There already is a patch rpm in rawhide (built at the time of the report), so we
already have a patch for the case of i386.
Comment 4 Trond Eivind Glomsrxd 2002-06-20 10:12:00 EDT
*** Bug 67115 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2002-11-13 08:49:30 EST
This bug was fixed ages ago in released erratum for RHL 7.3, but the
report never closed.  The package is: psmisc-20.2-3.73

Closing with resolution ERRATA

Note You need to log in before you can comment on or make changes to this bug.