Bug 64690 - ppp gets hosed, can no longer connect with isp
Summary: ppp gets hosed, can no longer connect with isp
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-09 18:29 UTC by Steve Wells
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 16:06:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Wells 2002-05-09 18:29:31 UTC
Description of Problem:
ppp reports problems trying to connect with ISP (in this case Earthlink and 
others), then no longer allows a subsequent dial-up connection to work, even if 
lcp timeout extended, until the system is restarted

Version-Release number of selected component (if applicable):


How Reproducible:
once a day

Steps to Reproduce:
1. configure ppp & diald for ISP
2. have program periodically (hourly) open socket to internet url
3. periodically socket will end up timing out and ppp log reveals results

Actual Results:
May  8 22:21:53 00-06-1E-00-10-B8 pppd[19211]: Receive serial link is not 8-bit
clean:
May  8 22:21:53 00-06-1E-00-10-B8 pppd[19211]: Problem: all had even parity
May  8 22:21:53 00-06-1E-00-10-B8 pppd[19211]: Exit.
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: start sl0: SIOCSIFMETRIC: Operatio
n not supported
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: start sl0: RTNETLINK answers: No s
uch process
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: stop ppp0: Cannot find device "ppp
0"
May  8 22:21:54 00-06-1E-00-10-B8 modprobe: modprobe: Can't locate module ppp0
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: stop ppp0: SIOCSIFADDR: No such de
vice
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: stop ppp0: ppp0: unknown interface
: No such device
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: down ppp0: ppp0: unknown interface
: No such device
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: Disconnected. Call duration 31 sec
onds.
May  8 22:21:54 00-06-1E-00-10-B8 diald[639]: IP transmitted 0 bytes and receive
d 0 bytes.
May  8 22:21:55 00-06-1E-00-10-B8 diald[639]: Delaying 30 seconds before clear t
o dial.

-----


Expected Results:
ppp not to fail

Additional Information:

Comment 1 Thomas Woerner 2004-08-16 16:06:54 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.