Bug 64705 - missing package from errata?
Summary: missing package from errata?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
(Show other bugs)
Version: RHN Stable
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-09 20:22 UTC by Isaiah Weiner
Modified: 2008-08-01 16:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 20:09:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Isaiah Weiner 2002-05-09 20:22:34 UTC
Description of problem:
 I kickstarted a clean 7.1 system, entitled it with RHN.  system name/id 14444 
under cisco_ecs_iweiner associated org.

    Via RHN, I only applied:

RHBA-2002:050-05  Bug Fix Advisory  Updated up2date and rhn_register
clients available

    And then ran rhn_check:

# rhn_check -v
handle_action actionid = 3436231, version = 2
rhn_register-2.7.9-7.x.2.i3  Retrieved.
rhn_register-gnome-2.7.9-7.  Retrieved.
up2date-2.7.61-7.x.1.i386.r  Retrieved.
up2date-gnome-2.7.61-7.x.1.  Retrieved.
Preparing...
Installing /var/spool/up2date/rhn_register-2.7.9-7.x.2.i386.rpm...

Installing /var/spool/up2date/rhn_register-gnome-2.7.9-7.x.2.i386.rpm...
warning: /etc/sysconfig/rhn/up2date created as
/etc/sysconfig/rhn/up2date.rpmnew

Installing /var/spool/up2date/up2date-2.7.61-7.x.1.i386.rpm...

Installing /var/spool/up2date/up2date-gnome-2.7.61-7.x.1.i386.rpm...
Sending back response: (0, 'Packages were installed successfully', {})

    That was successful, I then clicked the red 'Update This System' button for 
the same system and ran rhn_check again.  Everything but the rpm errata 
worked.  I've snipped the output to that point:

# rhn_check -v
[snip]
handle_action actionid = 3436347, version = 2
Sending back response: (18, 'Failed: packages requested raised
dependency problems', {'failed_deps': ((('perl-Perl-RPM', '0.291', '2'), 
('librpm.so.0', ''), 16384, '', 0), (('perl-Perl-RPM', '0.291', '2'),
('librpmio.so.0', ''), 16384, '', 0)), 'version': '0', 'name':
'package.update.failed_deps'})

    In the above, the installation of the rpm errata fails due to a
dependency issue with perl-Perl-RPM, a package that shipped with RHL 7.1. Maybe 
someone just forgot to include it in the errata?

    So, I manually remove perl-Perl-RPM, rpm -e perl-Perl-RPM.

    Then tell RHN to update system again, then run rhn_check: ... and all is 
well, the rpm errata is applied without a problem.

    So, the question is, why wasn't an update to perl-Perl-RPM part of
errata, /or/ what is the right thing to do here?

    Also, there are updates to the dump and rmt packages in the 7.1 updates 
directory, but a full RHN update does not update these packages:

Version avail in updates   Version installed on system:
dump-0.4b25-1.71.0         dump-0.4b21-3
rmt-0.4b25-1.71.0          rmt-0.4b21-3

    Maybe the big red 'Update your system' button should be renamed to
'Apply all Errata', since it doesn't appear to update packages without an 
associated errata update?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install perl-Perl-RPM
2. push update

Additional info:

Comment 1 Greg DeKoenigsberg 2002-05-14 17:58:29 UTC
To paraphrase Isiaiah in 25 words or less:

So, the question is, why wasn't an update to perl-Perl-RPM part of errata, /or/
what is the right thing to do here?

Comment 2 Adrian Likins 2002-05-15 19:38:25 UTC
perl-Perl-RPM doesnt exist anymore, replaced with rpm-perl I belive.
rpm-perl obsoletes perl-Perl-RPM, but the current client has no
way of discovering that if nothing installed depends on perl-Perl-Rpm.

Will be fixed in the next major version of up2date.

Comment 3 Isaiah Weiner 2002-05-15 23:19:49 UTC
This doesn't answer the question, unless the answer is 'wait' which is pretty 
hard to do without a schedule for the next major up2date release.

There's several hundred systems with this package installed.  RHN doesn't 
remove packages yet, so what's the right thing to do?

Comment 4 Chip Turner 2002-05-30 20:09:09 UTC
isaiah, if you schedule a package install of the 'rpm-perl' package, up2date
should remove the old perl-RPM package.  if you could try this on a test system,
it should work and solve the problems.  this is a bit of a workaround than a
real solution, but it should get you moving again.

Comment 5 Brian Faustyn 2002-06-04 12:33:56 UTC
Chip's workaround is sufficient for Cisco in the short term.  Adrian plans on
implementing the client-side enhancements for the long term (fall '02). 


Comment 6 Brian Faustyn 2002-06-04 12:43:23 UTC
Chip's workaround is sufficient for Cisco in the short term.  Adrian plans on
implementing the client-side enhancements for the long term (fall '02).


Note You need to log in before you can comment on or make changes to this bug.