Bug 647191 - pam_console does not think I am logged into the console if I use pam_namespace /tmp
pam_console does not think I am logged into the console if I use pam_namespac...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-27 10:07 EDT by Daniel Walsh
Modified: 2010-11-02 10:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: pam-1.1.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-02 10:40:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2010-10-27 10:07:29 EDT
Description of problem:

pam_console should check @/tmp/.X11-unix/X0
Comment 1 Daniel Walsh 2010-10-27 10:12:01 EDT
This is serious because if you run rawhide, dbus stops working properly.
Comment 2 Tomas Mraz 2010-10-27 10:13:23 EDT
For checking it will have to use connect to the abstract AF_UNIX socket. I am not sure it will not require modification of SELinux policy as well.
Comment 3 Daniel Walsh 2010-10-27 11:07:05 EDT
As soon as you have one that works I will install and see if it needs policy changes.
Comment 4 Tomas Mraz 2010-11-02 10:40:04 EDT
Dan, please verify that pam-1.1.3-1.fc15 fixes the problem. If not, please reopen.

Note You need to log in before you can comment on or make changes to this bug.