Bug 647253 - Update RHEL Tomcat 5 builds to 5.5.33
Update RHEL Tomcat 5 builds to 5.5.33
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tomcat5 (Show other bugs)
5.9
All Linux
high Severity high
: rc
: ---
Assigned To: David Knox
tomcat-qe
: Rebase
Depends On: 818667
Blocks: 807971
  Show dependency treegraph
 
Reported: 2010-10-27 13:23 EDT by David Knox
Modified: 2015-11-01 19:16 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 09:39:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Knox 2010-10-27 13:23:18 EDT
Description of problem:
Tomcat bugfixes and security patches are currently based on tomcat5.5.30 (5.5.31 is the current stable community version). Applying patches meant for 5.5.30+ to 5.5.23 has increased in difficulty and introduces more risk of unwanted side-effects. The difficulty and risk continues to increase without a rebase. The additional bugfixes over 7 minor revs, and reduced risk of patching warrant an update to 5.5.30 is worth the effort.

Note: This update is not proposed for 5.5.z build unless our z-stream customers are specifically asking for it. But, the difficulty in patching the z-stream tomcat5 code base will continue to increase. 


Version-Release number of selected component (if applicable):
tomcat 5.5.23


Additional info:
Comment 1 RHEL Product and Program Management 2011-01-11 15:48:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2011-01-12 10:15:50 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 3 David Knox 2011-02-17 12:48:28 EST
Updated the tc version to 5.5.33. Tomcat 5.5.23 is unsupportable because all security patches in the future will be based on 5.5.33. which is the current stable community release. The tc 5.5.23 is unsupported by the community.
Comment 4 RHEL Product and Program Management 2011-05-31 10:11:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-04-02 06:31:10 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Note You need to log in before you can comment on or make changes to this bug.