Bug 6473 - Installer tries to mount cm206 device instead of cm206cd and fails
Installer tries to mount cm206 device instead of cm206cd and fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-28 13:52 EDT by jonathan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 08:45:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonathan 1999-10-28 13:52:27 EDT
While trying to do a cdrom install on a machine with a
Phillips 206 CDrom drive, the installer program fails to
mount the cd.

It prints on the installer log console:
* trying to mount device cm206

However, by taking a look at the source code for anaconda,
I found in anaconda/loader/cdrom.[ch] and loader.c that the
cdrom tables correctly identify that the module cm206 has a
device name of cm206cd and should be mounting that name.

I traced through the code paths and I don't see how the
wrong device name is getting set, the code looks right, but
I have no way of debugging what is really happening during
the install because the system isn't working yet.

The cdrom drive works fine using the cm206 driver in the
current installation of redhat linux I have on this machine
(Redhat 3.0.3 with 2.0.13 kernel) and I think the entire
problem is that you are trying to mount a device called
cm206 when the device name should be cm206cd.

This is a big problem since it is impossible to do a cd
install now, and I tried a nfs install and that had a
problem where it took a second to read each 4k block over
nfs so after 20 minutes of not loading the second stage
loader I gave up. (This is probably a second bug since the
networking on this machine worked fine in my old redhat
installation.)
Comment 1 Jay Turner 1999-10-29 13:33:59 EDT
This issue has been assigned to a developer for further action.

Note You need to log in before you can comment on or make changes to this bug.