Bug 64735 - Atomic ops removed from atomic.h
Atomic ops removed from atomic.h
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc-kernheaders (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 06:33 EDT by larsbj
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 13:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description larsbj 2002-05-10 06:33:58 EDT
Description of Problem:

All programs that used the atomic ops from asm/atomic.h now failes to compile.

Version-Release number of selected component (if applicable):

2.4 7.14
Comment 1 Arjan van de Ven 2002-05-20 05:21:39 EDT
1) Those were internal (and GPL) kernel inlines
2) even when used, in userspace that header file didn't
   actually provide atomic operations.... it might have LOOKED 
   like they were though.....
Comment 2 Alistair Riddoch 2002-06-26 10:29:35 EDT
Could you clarify the status of this bug?

Were the operations expressly removed from the header, because they are not
atomic?

Is it the intention to leave the header in this state?

What is the recommended solution for compiling applications which rely on
the presence of these operations?
Comment 3 Arjan van de Ven 2002-06-26 10:33:57 EDT
> Were the operations expressly removed from the header, because they are not
> atomic?

Well that and the fact that these things are not portable (not all architectures
even HAVE such operations that are compilable in userspace)


> Is it the intention to leave the header in this state?

yes

> What is the recommended solution for compiling applications which rely on
> the presence of these operations?

if the (GPL) app *really* wants, it can obviously copy the code from the kernel
into it's own code and actually hack the assembly to be atomic.

Note You need to log in before you can comment on or make changes to this bug.