Bug 647355 - docs.redhat.com navigation menu is very slow
docs.redhat.com navigation menu is very slow
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Hideo
Fedora Extras Quality Assurance
:
Depends On: 640164
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-27 22:52 EDT by Michael Hideo
Modified: 2010-11-23 23:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 640164
Environment:
Last Closed: 2010-11-23 19:02:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hideo 2010-10-27 22:52:20 EDT
Any quick and easy way to increase the load speed of the nav menu?



+++ This bug was initially created as a clone of Bug #640164 +++

Hi.

The new left-side navigation menu on docs.redhat.com is extremely slow.

Without Red Hat VPN connection it's quite slow, and with VPN connection
it's extremely slow, almost unusable.


It seems the new Javascript code does something quite strange, and
reloads the whole navigation menu on each page load. Doesn't seem to be
CPU intensive, but rather a network issue?


Typically the navigation menu loads/renders about 1-3 lines per second,
causing the whole menu rendering time to be about 1-2 minutes from reload.


-- 
Toni Willberg
Solution Architect
Red Hat Finland - Keilasatama 3 - 02150 Espoo - Finland
Mobile: +358 45 123 1293
Comment 3 Jeff Fearn 2010-11-23 19:02:38 EST
This is not a bug in publican, it was addressed by web server reconfiguration.

Note You need to log in before you can comment on or make changes to this bug.