Bug 64741 - Installer crashes midway through upgrade with compression error
Installer crashes midway through upgrade with compression error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 08:00 EDT by Olivier Crête
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 15:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 2002-05-10 08:00:48 EDT
Description of problem:
Anaconda crashes about half way through the upgradel while installing the
package 300/600.... If I try to disable that package, it will just crash at
another package at the same spot (the rank seems to be the important factor, not
the package itself)

How reproducible:
Always

Steps to Reproduce:
1. Boot into installer
2. choose upgrade from harddisk
3. just select the fault options
	

Actual Results:  In tty1 (ncurses interface) I get this message, but I get it
way before it freezes, so I'm not sure at all if its related:
***PSM_RDB_LOAD: head #730 not found

But the interesting message is on tty4: the <6> fill the whole screen..
<6> 01:01: rw=0, want=5617, limit=4608
<6> attempt to access beyond end of device
<6> 01:01: rw=0, want=5617, limit=4608
<6> attempt to access beyond end of device
<6> 01:01: rw=0, want=5617, limit=4608
<6> attempt to access beyond end of device
<6> 01:01: rw=0, want=5617, limit=4608
<6> attempt to access beyond end of device
<6> 01:01: rw=0, want=5617, limit=4608
<6> attempt to access beyond end of device
<4> Error -3 while decompressing
<4> c02a44f6(2219)->cc680000(4096)
<4> Error -3 while decompressing
<4> c02a6ec0(600)->cbd5700(4096)


Additional info:

The error messages where copied by hand... I checked the md5 on the isos more
than once, so I'm pretty that they are correct. It leaves a half updated system
where some packages do not work.. (ie. up2date segfaults...)
Comment 1 Olivier Crête 2002-05-10 08:13:13 EDT
err. up2date crashing was due to LD_PRELOADing gdkxft.... on a gtk+2 app...
Comment 2 Michael Fulbright 2002-05-10 11:43:26 EDT
Please boot the installer with 'linux mediacheck' and test the ISO images on
your harddrive for errors.
Comment 3 Olivier Crête 2002-05-10 12:10:28 EDT
As I said I the original bug report... md5sum -c tells me that they are perfect...
I'll try mediacheck...
Comment 4 Michael Fulbright 2002-05-13 15:23:27 EDT
Make sure you run the test on the same machine you are having problems
installing on. I've had dozens of bug reports where different CD drive read CDs
differently.
Comment 5 Olivier Crête 2002-05-13 15:39:19 EDT
It is not a CD install, but a HD install. And the ISOs where on the root ext3
partition of the system being upgraded... So it's not a cdrom problem.
I ended up just upgraded the redhat-release package and then running up2date...
Why dont you support that method for upgrades? It would be much easier...
(debian like in place upgrade...)

I tried doing a NFS upgrade from the same ISOs, but on a different system and it
worked perfectly (no problem with the mediacheck) and the upgrade was very smooth.
Comment 6 Michael Fulbright 2002-05-13 16:26:04 EDT
Glad to hear your found a workaround!

Note You need to log in before you can comment on or make changes to this bug.