Bug 64756 - Flash plugin does not work on Konqueror 3.0.0-12 on a freshly installed Red Hat 7.3
Flash plugin does not work on Konqueror 3.0.0-12 on a freshly installed Red H...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 12:02 EDT by Alex Dusty
Modified: 2006-07-08 03:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 03:28:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Dusty 2002-05-10 12:02:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
The plugin is not started, even if everything seems well configured. I tried to upgrade the plugin to the latest release (5.0.48.0) from the macromedia site but that did not solved the problem.
The plugin works great under mozilla and netscape, tough.
That's a blocking issue for me (I develop flash applications), and prefer konqueror as a browser for a number of reasons.
The plugin worked fine with the previous release, under Red Hat 7.2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open a web page with a flash applet, as www.macromedia.com
2. the plugin is not started
3.
 

Additional info:
Comment 1 Rex Dieter 2002-05-13 13:41:11 EDT
I get offer a "me too".  I found further that if I directly reference the flash 
file in the Address URL box, it loads and runs.  I just can't get it to work 
when embedded into a webpage.
Comment 2 Rex Dieter 2002-05-13 16:07:41 EDT
I found an example of a flash site not loading (don't laugh):  
http://www.duranduran.com/  
This USED to work with kde-2.2.2.  
   
I'm also getting similar (but not as drastic) failures on some sites with 
embedded java applets.  Sometimes they load, sometimes they don't.   
http://java.sun.com/ 
is a good example, there's supposed to be 2 applets, but I can only get at 
most one of them to work (by reloading).  I've tried both jre1.3.1_02 and 
jre1.4.0 from sun (rpm).
Comment 3 Rex Dieter 2002-05-15 11:46:49 EDT
Just snagged kde 3.0.1-1 packages from rawhide. java applets now seem to load 
reliably.  I also found an example of a flash site that actually works: 
http://www.planettribes.com/allyourbase/video.shtml (I think this uses 
flash4).
Comment 4 Carlos Rodrigues 2002-06-22 14:53:07 EDT
The problem is khtml doesn't correctly interpret the <object> tag and thus, 
flash animations which are not inside a <object></object> pair work ok. Like 
the one above.
Comment 5 Bernhard Rosenkraenzer 2002-07-01 07:18:41 EDT
Accessing any of those pages with 3.0.2-1 gives me a warning saying no plugin 
for swf found and a large reserved area, so I think the <object> parsing stuff 
is fixed. 
Comment 6 Rex Dieter 2002-07-02 09:53:27 EDT
I can verify that with kdelibs-3.0.2-0.cvs20020625 and 
kdebase-3.0.2-0.cvs20020627 (from rawhide), and the flash5 plugin from 
macromedia, that the flash portions of webpages now actually load and work.  
So when do we get to see 3.0.2-1?  (-:

Note You need to log in before you can comment on or make changes to this bug.