Bug 64769 - i810_audio module does not work with AC97 controller
i810_audio module does not work with AC97 controller
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 14:30 EDT by Robert
Modified: 2014-01-21 17:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 15:09:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert 2002-05-10 14:30:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
My system has an ac97 audio controller, the i810_audio module is suposed to work
with this device. The module loads just fine but I get no sound. There are no
error messages and all programs work fine there is just no sound output. My
system in an IBM Netvista 2292. I called RedHat support and the technician told
me log a bug report because it is configured properly and it is still not
working. He also said that there was some discussion in your forums about this
issue. My support order number was I2413388 if that helps. The hardware is
working fine because it works in windows.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Reboot
2.i810_audio module loads
3.attempt to play a sound file (used play and xmms)
4. no sound output
	

Actual Results:  No Sound

Expected Results:  should hea wav file or mp3 file

Additional info:
Comment 1 Robert 2002-05-10 14:31:50 EDT
Just an FYI I had the same problem in Redhat 7.2
Comment 2 Doug Ledford 2002-05-16 16:19:20 EDT
Are you running in KDE or in Gnome?
Comment 3 Robert 2002-05-16 19:06:44 EDT
I am using Gnome, but I also tried KDE and I tried from just theconsole using
'play' None worked The most I ever got was some popping and clicking when
adjusting the volume.
Comment 4 Doug Ledford 2002-05-16 19:30:23 EDT
When in Gnome, run the sound mixer app, try adjusting the PCM2 volume and see if
that starts sound output working.  In some i810 configurations, the PCM2 volume
control actually acts as the main volume while the main volume control does
nothing (this is related to how the chip is hardwired on the motherboard and
there currently is no way for the i810 driver to know that it is wired in this
odd way, but I can say that my Dell Precision Workstation 330 is this way).  Let
me know if that solves your sound output issue.
Comment 5 Need Real Name 2002-05-21 11:51:52 EDT
 I have the same problem with a Netvista 6792, when I run snd 
config detects the AC97 controller but don't play the test 
sound, and I login in kde after reboot and only shows a 
dialog after a few minutes about sound server overload or 
something like that. 
the machine is a P4@1.6GHz and the contents of 
/var/log/messages is: 
 
May 20 15:28:17 g1 kernel: Intel 810 + AC97 Audio, version 
0.21, 18:54:58 May  2 
 2002 
May 20 15:28:17 g1 kernel: PCI: Setting latency timer of 
device 00:1f.5 to 64 
May 20 15:28:17 g1 kernel: i810: Intel ICH2 found at IO 
0x1840 and 0x1c00, IRQ 5 
May 20 15:28:17 g1 kernel: i810_audio: Audio Controller 
supports 6 channels. 
May 20 15:28:17 g1 kernel: ac97_codec: AC97 Audio codec, id: 
0x4144:0x5362 (Unkn 
own) 
May 20 15:28:17 g1 kernel: i810_audio: AC'97 codec 0 Unable 
to map surround DAC' 
s (or DAC's not present), total channels = 2 
May 20 15:28:17 g1 modprobe: modprobe: Can't locate module 
sound-service-0-0 
May 20 15:28:17 g1 modprobe: modprobe: Can't locate module 
sound-slot-1 
May 20 15:28:17 g1 modprobe: modprobe: Can't locate module 
sound-service-1-0 
May 20 15:28:18 g1 modprobe: modprobe: Can't locate module 
sound-slot-1 
May 20 15:28:18 g1 modprobe: modprobe: Can't locate module 
sound-service-1-0 
 
 
 
the output of lspci is: 
 
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) 
Chipset Host Bridge (rev 
03) 
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset 
AGP Bridge (rev 03 
) 
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA PCI Bridge (rev 
12) 
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 
12) 
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 12) 
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub  
(rev 12) 
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 12) 
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub  
(rev 12) 
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM 
AC'97 Audio (rev 12 
) 
01:00.0 VGA compatible controller: nVidia Corporation NV6 
[Vanta] (rev 15) 
02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM 
Ethernet Controller 
(rev 03) 
02:0e.0 Ethernet controller: 3Com Corporation 3c905B 
100BaseTX [Cyclone] (rev 34 
 
the contents of /etc/modules.conf: 
alias sound-slot-0 i810_audio 
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc 
-L >/dev/null 2>&1 
 || : 
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc 
-S >/dev/null 2>&1 | 
| : 
 
 
thanks in advance, 
 
Gabriel
Comment 6 Robert 2002-05-21 11:59:51 EDT
No its not the volume. As my previous comment indicated I tried adjusting ALL 
of the volume controls via the gnome mixer and aumix.
Comment 7 Doug Ledford 2002-05-23 19:55:50 EDT
OK, I can't reproduce this here (don't have the correct hardware).  I'm going to
have to try and hunt down an i845 based system to test this on before I can do
much of anything with this bug.
Comment 8 Shawn D. Kelly 2002-06-30 02:31:15 EDT
Count me in - under 7.2 and 7.3, I get the same modprobe messages that gabriel 
is getting.  I'm running an ABit SE6 with Intel 815E chipset.
Comment 9 Thomas M Steenholdt 2002-07-15 08:02:03 EDT
Same problem here... IBM NetVista 6825-12G

Only tried this with 7.3

lspci (in case it should make any difference):
----------
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA PCI Bridge (rev 12)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 12)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 12)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub  (rev 12)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 12)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub  (rev 12)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 12)
01:00.0 VGA compatible controller: nVidia Corporation NV6 [Vanta] (rev 15)
02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller
(rev 03)
02:0e.0 Token ring network controller: IBM 16/4 Token ring UTP/STP controller
(rev 05)
---------

Comment 10 Thomas M Steenholdt 2002-07-17 03:45:33 EDT
I decided to try the same machine with RH 7.3.92(limbo) - The same problem
exists on the beta!
when pressing the test sound button in the firstboot screen, the following
message appears on tty1 where I was logged in as root...

sox: Sound card appears to only support 2 channels. Overriding format.

Please let me know if I need to somehow move this bug into the RH beta product
as well...
Comment 11 Thomas M Steenholdt 2002-07-31 02:05:12 EDT
Red Hat Limbo 7.3.93 still has this problem on my machine...

Please let me know what kind of information you need to help squat this bug and
I will do my very best to provide you with it
Comment 12 Doug Ledford 2002-08-08 16:38:50 EDT
I've found a problem in the i810 driver that causes symptoms much like what you
are reporting.  The new 0.22 version of the driver *should* solve your problem.
 Look for it to show up in the next beta release and an upcoming errata (not the
next kernel errata unfortunately, it's already in QA and it's too late for me to
get a new patch in).  People wishing to test this out can contact me directly
and I can send you modules that should work on your machine.
Comment 13 andrew m. boardman 2002-08-09 14:15:02 EDT
Thanks, this does indeed get all of our IBMs working.
Comment 14 Thomas M Steenholdt 2002-08-14 04:02:02 EDT
even though I actually get sound on my machine now, there seems to be some kind
of DMA problemm, still...

steps to reproduce (on my machine at least):
1. boot computer
2. switch to tty1 (CTRL+ALT+1)
3. do "playwave /usr/share/sounds/KDE_Startup_new.wav"
4. while sound is playing, switch back to X on tty7 (CTRL+ALT+7)
5. sound is severely corrupted by that, each time on this machine

I get errors that look something like:
i801_audio: DMA overrun on write
i801_audio: CIV 0, LVI 31, hwptr 262, count -610

when subsequently killing the playwave process from tty2 (killall playwave), i get:
i810_audio: drain dac, dma timeout?
Comment 15 Need Real Name 2002-08-31 13:00:16 EDT
 I tried the new module with kernel 2.4.18-5 and when I hear the sample sound 
in sndconfig, in kde only hear noise when I play sounds so maytbe I have 
misconfigured the sound in kde or the new module doesn't work in my netvista 
6792-11S. 
Comment 16 Thomas M Steenholdt 2002-10-18 01:52:17 EDT
I think that at least kernel 2.4.18-17.8.0 seems to work pretty well... I still
think I get some "cuts" in the sound when doing things like switching to/from
terminal/X but the drain_dac errors and the real sound corruption appear to have
gone... The volume control doesn't work in gnome, though - it seems that the
device needs it's volume controlled on the PCM channel instead of the main
volume channel - is this a hardware or driver or volume-control applet issue?
Comment 17 Alan Cox 2003-06-10 15:09:59 EDT
Hardware

Note You need to log in before you can comment on or make changes to this bug.