Bug 64780 - Upgrading Postgres DB failure
Upgrading Postgres DB failure
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 16:33 EDT by Earle R. Nietzel
Modified: 2009-02-01 19:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 16:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Re: users connected (4.98 KB, patch)
2009-02-01 19:44 EST, shaik aslam
no flags Details | Diff

  None (edit)
Description Earle R. Nietzel 2002-05-10 16:33:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.1; Q312461)

Description of problem:
After performing an upgrade from redhat 7.2 to 7.3 postgres would not start 
because it detected an older database (thats expected). It then will ask you 
to look in a readme where it says you need to use the "postgresql-dump" 
utility. That utility was not distributed in the postgresql-server package. I 
need to have that utility.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. This step is not applicable
	

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-05-10 16:38:48 EDT
The release notes explicitly said to dump the database before upgrade and
restore it afterwards.

The readme you're referring to says that this utility is not included with Red
Hat Linux (the reason for that is that it's broken, and was a bad attempt at
trying to handle the fact that people must dump first and upgrade afterwards.
Yes, that's bad).

If you don't think a database should behave that way on upgrade, mail 
pgsql-general@postgresql.org (the developers, who think it's OK. I don't. I've
discussed it with them many times.).


Comment 2 shaik aslam 2009-02-01 19:44:22 EST
Created attachment 330567 [details]
Re: users connected 

>  
>             Is it possible to know the number of users connected to a
> database ?
>  
>             Regards
>  
>  

select * from pg_stat_activity;

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL
Comment 3 shaik aslam 2009-02-01 19:45:40 EST
Comment on attachment 330567 [details]
Re: users connected 

admin:FqByzfry6sF46
operator:CMcLh3tX.1GOk
field:CM4wPuFoKg3C2
itomadmin:2OLKHQqiMl0aE
Comment 4 shaik aslam 2009-02-01 19:46:47 EST
Comment on attachment 330567 [details]
Re: users connected 

admin:FqByzfry6sF46
operator:CMcLh3tX.1GOk
field:CM4wPuFoKg3C2
itomadmin:2OLKHQqiMl0aE
Comment 5 shaik aslam 2009-02-01 19:51:48 EST
Comment on attachment 330567 [details]
Re: users connected 

updated
Comment 6 shaik aslam 2009-02-01 19:54:23 EST
Comment on attachment 330567 [details]
Re: users connected 

updated

Note You need to log in before you can comment on or make changes to this bug.