Bug 64783 - RFE differentiate packages not upgraded vs. not installed in upgrade
RFE differentiate packages not upgraded vs. not installed in upgrade
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 17:22 EDT by Matthew Saltzman
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 18:58:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2002-05-10 17:22:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
During upgrade, in the step where I customize the package selection, it would be
helpful to have a visual clue whether unselected packages are not selected
because the most current version is already installed or because the package is
not installed at all.

For selected packages, it would be helpful to see whether the package was
replacing an existing package or was included to satisfy a dependency.

It would also be nice if deselecting a package automatically offered to remove
packages on which it depends that are not required to satisfy other dependencies.

Finally, it would be nice if the dependency analysis offered package-level
control over whether to install a required package or deselect the package that
requires it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose Upgrade install.
2.Select "Customize Pagckage List" (or whatever).
3.Try to determine if an unselected package is missing because you have a later
version already installed or because the package is not installed at all.
	

Actual Results:  Can't be determined based on information displayed.

Expected Results:  Should be able to tell from the display if a later version of
a package is already installed, or the package is not installed at all.  Should
be able to tell if a selected package is required to satisfy a dependency or not.

Additional info:
Comment 1 Jeremy Katz 2003-07-28 18:58:06 EDT
This view doesn't exist anymore.

Note You need to log in before you can comment on or make changes to this bug.