Bug 64788 - Hard disk partitioning problems on Promise FastTrak66 Controller
Hard disk partitioning problems on Promise FastTrak66 Controller
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 18:20 EDT by Joe Bange
Modified: 2007-04-18 12:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 22:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Bange 2002-05-10 18:20:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
Anaconda returns the error...
"The kernel was unable to re-read the partition table on /tmp/hde (device or 
resource busy).  This means that Linux knows nothing about any modifications 
you made.  You should reboot your computer before doing anything with /tmp/hde" 
just before installing packages.  An ignore button is presented.  If you 
ignore, install will continue, but the system will not boot on restart.  This 
server has a Promise FastTrak66 IDE RAID controller in it.  Note that RedHat 
7.2, and other Linux distributions, all install and boot properly on this 
server as configured.  My assumption is that there is a problem with the 
default 2.4.18-3BOOT kernel that is being used during install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot RHL 7.3 from CD/Boot Floppies.
2.Begin installation.  Manually or automatically partition.
3.Pop-up error is presented, either ignore or reboot and re-label disks.
4.Continue/complete installation.
5.Reboot

Server will not boot from boot floppy or HDD.

	

Actual Results:  When using the 7.3 Anaconda installer, the installer appears 
to unsuccessfully partition the server.  Post partitioning, just before you 
install the packages, Anaconda returns the following pop-up message...
"The kernel was unable to re-read the partition table on /tmp/hde (device or 
resource busy).  This means that Linux knows nothing about any modifications 
you made.  You should reboot your computer before doing anything with /tmp/hde"

Even if you reboot and re-label your partitions, the pop-up message will appear.

Should you decide to manually partition, the end result is the same.

Notably, when using fdisk to partition the disk, as you write the partition 
table and attempt to exit fdisk, fdisk returns...
"WARNING: Re-reading the partition table failed with error 16: Device or 
resource busy.  The kernel uses the old table.  The new table will be used at 
the next reboot.  Syncing disks."

It appears that the kernel is unable to read the new partition table under 
**any** circumstances, regardless of the number of reboots or re-partitioning 
operations that take place.

  


Expected Results:  Proper partitioning and correct re-reading of the partition 
table during install should result in a successful install.

Additional info:

Note that RHL 7.2, as well as other recent Linux distributions, install and 
boot properly on this server as configured.

Server is equipped with a Western Digital WD205BA 20 GB drive on a Promise 
FastTrak66 controller with the PDC20262 chipset.

Note that also under certain circumstances, depending on partitioning scheme, 
that Anaconda will report an error initializing the swap partition.  Namely 
when doing the custom install with auto-partitioning selected.
Comment 1 Joe Bange 2002-05-10 18:22:59 EDT
Note that upgrades of a RHL 7.2 installation are completely successful on this 
same system.  Only clean installs that require partitioning or formatting of 
the HDD cause this installation failure.
Comment 2 Davide Rossetti 2002-06-27 11:28:28 EDT
Same problem on my GigaByte GS-SR101 1U rackmount server.
System highlights:
- IDE CDROM on hdc (VIA IDE ctrl)
- 2 IDE disks on the integrated Promise FastTrack100 ctrl

trying partitioning >1 times (2,3 or even 4 times may be necessary, rebooting
each time) seem to be the only work around.

I even tried to use fdisk many times, 4-5 times entering fdisk, exiting it,
reentering...
Comment 3 Samuel Flory 2002-07-10 15:37:03 EDT
  I've also seen this when using a tyan 2515 with an on board fasttrak
controller.  The interesting fact was that I could drop to a console and run
fdisk by hand with no issues.  When I used disk druid or fdisk via the installer
I got "The kernel was unable to re-read the partition table..." message.  As
long as I may no changes to the partition table I was able to install despite
the warnings.
Comment 4 chun ming li 2002-07-29 16:56:53 EDT
Seen same problem on Intel Server with ICH3 controller.  If I make any changes 
to the partition table it would give the "The kernel was unable to re-read the 
partition table on /tmp/hda (device or 
resource busy)" message.  The interesting thing is I get this problem with 
Seagate Barracuda drives but NOT with Maxtor IDE drive model 4G16OJ8.  Droping 
to the console and fdisk workaround does not work for me.
Comment 5 Samuel Flory 2002-07-31 15:22:16 EDT
  This also occurs on limbo as well.
Comment 6 chun ming li 2002-08-22 12:26:35 EDT
This seem to be a installer failure.  After installing the OS to a SCSI drive 
and booting run level 1, I can use fdisk to partition the failing IDE drive 
with out problem.
REPRODUCED failure with Null.
Comment 7 chun ming li 2002-08-22 12:43:29 EDT
Additional info:
Failure can be reproduced in systems with and without onboard Promise 
controller.  Also this does not look like to be chipset specific, same problem 
exist on Serverworks GC-LE and Intel Pluma chipset.

Comment 8 Davide Rossetti 2002-08-22 12:48:13 EDT
it seems to be a problem with the boot kernel. I was surprised that Update
kernels do not also show up as kernel images....
Comment 9 Samuel Flory 2002-08-22 18:34:42 EDT
To make things even more strange.  The intel clearwater (cw2) /w promise
installs without a hitch, but the Tyan 2515 doesn't have an issue.  I'll try and
get lspci -v on both systems, but the driver reported the same chipset.
Comment 10 Samuel Flory 2002-08-22 18:57:34 EDT
Make that the tyan 2515 does stil have the issue.
Comment 11 Samuel Flory 2002-08-26 15:49:12 EDT
  The intel S845WD1 is unable to update the partition table in the null
installer.  This occurs with the promise, and non promise ide interfaces.  You
can install if you don't attempt to change the existing partition table.  

  Once installed the std kernel, and the BOOT kernel can update the partition
table via fdisk. (Assuming you don't have the drive mounted or used as a swap
device.)
Comment 12 Matt Wilson 2002-08-28 17:21:01 EDT
All:  I need a full matrix of the chipsets and drives used that experience this
problem
Comment 13 chun ming li 2002-08-28 19:38:23 EDT
Failure reproduce on Red Hat 7.3, Limbo and NUllwith following configurations.
Chipset: SeverWorks HELE with CSB5 IDE interface
Chipset: Intel E7500(Plumas) with 82801CA(ICH3) IDE interface
Chipset: Intel S845 with ICH3
Failing IDE drives:
Seagate ST380021A        -failed
Fujitsu  MPG3204AH         -failed
Seagate ST340016A         -failed

Note:  Failure can NOT be reproduced with other distrution of Linux or earlier 
version of Red Hat. ie Rh7.2/7.1.  Also if RH7.3 is install to SCSI drive, you 
will have NO problem using fdisk to partition the failing IDE drives listed 
above.
Comment 14 Davide Rossetti 2002-08-29 14:35:22 EDT
for my Gigabyte GS-SR101:

the problem showed installing on hde.

/proc/pci:

  Bus  0, device   0, function  0:
    Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 196).
      Master Capable.  Latency=16.  
      Prefetchable 32 bit memory at 0xe0000000 [0xe3ffffff].
  Bus  0, device   1, function  0:
    PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
(rev 0
).
      Master Capable.  No bursts.  Min Gnt=8.
  ...
  Bus  0, device   7, function  1:
    IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 6).
      Master Capable.  Latency=32.  
      I/O at 0xffa0 [0xffaf].
  ...
  Bus  0, device   7, function  4:
    SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 64).
  ...

  Bus  0, device  16, function  0:
    RAID bus controller: Promise Technology, Inc. 20265 (rev 2).
      IRQ 10.
      Master Capable.  Latency=64.  
      I/O at 0xdc00 [0xdc07].
      I/O at 0xd800 [0xd803].
      I/O at 0xd400 [0xd407].
      I/O at 0xd000 [0xd003].
      I/O at 0xcc00 [0xcc3f].
      Non-prefetchable 32 bit memory at 0xdffe0000 [0xdfffffff].


IDE disk boot log (with 2.4.18-10smp):

VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci00:07.1
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
PDC20265: IDE controller on PCI bus 00 dev 80
PDC20265: chipset revision 2
ide: Found promise 20265 in RAID mode.
PDC20265: not 100% native mode: will probe irqs later
PDC20265: ROM enabled at 0xdffd0000
PDC20265: (U)DMA Burst Bit ENABLED Primary MASTER Mode Secondary MASTER Mode.
    ide2: BM-DMA at 0xcc00-0xcc07, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xcc08-0xcc0f, BIOS settings: hdg:pio, hdh:pio
hdc: SR243T, ATAPI CD/DVD-ROM drive
hde: IC35L060AVER07-0, ATA DISK drive
hdg: IC35L060AVER07-0, ATA DISK drive
ide1 at 0x170-0x177,0x376 on irq 15
ide2 at 0xdc00-0xdc07,0xd802 on irq 10
ide3 at 0xd400-0xd407,0xd002 on irq 10
blk: queue c03d494c, I/O limit 4095Mb (mask 0xffffffff)
hde: 120103200 sectors (61493 MB) w/1916KiB Cache, CHS=119150/16/63, UDMA(100)
blk: queue c03d4cb0, I/O limit 4095Mb (mask 0xffffffff)
hdg: 120103200 sectors (61493 MB) w/1916KiB Cache, CHS=119150/16/63, UDMA(100)
....
VFS: Mounted root (ext2 filesystem).
 ataraid/d0: ataraid/d0p1 ataraid/d0p2 ataraid/d0p3 < ataraid/d0p5 ataraid/d0p6
atara
id/d0p7 ataraid/d0p8 ataraid/d0p9 >
Drive 0 is 58644 Mb (33 / 0) 
Drive 1 is 58644 Mb (34 / 0) 
Raid1 array consists of 2 drives. 
Promise Fasttrak(tm) Softwareraid driver for linux version 0.03beta
Comment 15 Samuel Flory 2002-08-29 15:28:51 EDT
The intel S845WD1 (from 2.4.20pre4-ac1):
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH2: IDE controller on PCI bus 00 dev f9
ICH2: chipset revision 5
ICH2: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
hda: ST340824A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: Maxtor 5T040H4, ATA DISK drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63, UDMA(100)
hdc: host protected area => 1
hdc: 80043264 sectors (40982 MB) w/2048KiB Cache, CHS=79408/16/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 hda3 hda4
 hdc: hdc1

I'll try and get the dmesg off of the tyan 2515 as well.
Comment 16 Jeremy Katz 2003-10-21 19:58:29 EDT
Do you see this with Red Hat Linux 9 / the Fedora test releases?
Comment 17 Jeremy Katz 2004-10-04 22:36:52 EDT
Closing due to lack of activity.  Please reopen if you have further
information to add to this report.

Note You need to log in before you can comment on or make changes to this bug.