Bug 64789 - XConfigurator Will Not Run
XConfigurator Will Not Run
Status: CLOSED DUPLICATE of bug 64544
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-05-10 18:23 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-04 03:29:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-10 18:23:51 EDT
Description of Problem:
I installed RH 7.3 on my Pentium 233 PC and the setup went fine.  Once the PC 
rebooted, I logged on as root and ran 'startx'.  Xserver claimed to not be 
configured, so I ran XConfigurator.  The initial screen came up and when I hit 
enter, the blue background remained for about 30 seconds and then I was dropped 
back out to my command line prompt.  Above the prompt, there were two words on 
the screen, "Segmentation fault."  That was the only "error message" I recieved.
Still, I cannot run X.  I have tried rebooting and also re-installing and still 
have the same problem.

Version-Release number of selected component (if applicable):  Unsure.

How Reproducible:
Every time I try to run XConfigurator.

Steps to Reproduce:
1. Installed RH7.3 on a Compaq Presario 4808 (Intel Pentium 233). 
2. After system reboots to the text login (default), logged in as root.
3. Ran XConfigurator

Actual Results:
Initial screen displays until <Enter> key is pressed.  Once <Enter> is pressed, 
drops back to the prompt and displays "Segmentation fault" one line above the 
prompt.  Screen background stays blue.

Expected Results:
To be able to completely configure my video card, monitor, screen colors and 

Additional Information:
Downloaded the ISO images from a mirror site (ftp.ttu.edu).  md5 checksum was 
valid for each of the ISO images.  Burned the ISO images to CDs.  Booted from 
Disc 1 and ran 'linux mediacheck' and all 3 CDs passed.  Installed RH7.3 the 
first time in normal mode (GUI) and the second time in text mode.  According to 
the installation program, everything installed fine (I selected "Everything" in 
the "Packages to Install" screen).  My PC has a 20 gig hard drive and 12 gig of 
it is used for the Linux installation.
Comment 1 Mike A. Harris 2002-05-13 03:05:18 EDT
You haven't indicated what video card you have.  Please provide that, as
well as the output of:

lspci -n
Comment 2 Mike A. Harris 2002-05-27 12:22:06 EDT
Please attach the information that has been requested, or there is nothing
that can be done about your bug report.  Xconfigurator works fine, so if
it does not work for you, then it is something hardware specific, and I do
not know what video hardware you have.
Comment 3 Antoni Reus 2002-06-04 02:54:45 EDT
Same problem here.

Pentium 200 mmx. The video card is a S3 Trio64V2/DX.
During the installation the card is configured properly, identified as
a Trio64V (generic)

But after installation X wont work, displaying the message "display driver is
not found".

Runnig Xconfigurator get a Segmentation Fault, after the presentation screen.

Note: With Redhat 7.2 it was working properly.
Comment 4 Antoni Reus 2002-06-04 03:08:59 EDT
Here is lspci -n

00:00.0 Class 0600: 1106:1595 (rev 03)
00:02.0 Class 0200: 10b7:9050
00:03.0 Class 0200: 10b7:9050
00:04.0 Class 0200: 10b7:9050
00:07.0 Class 0601: 1106:0586 (rev 31)
00:07.1 Class 0101: 1106:0571 (rev 06)
00:07.2 Class 0c03: 1106:3038 (rev 02)
00:07.3 Class 0000: 1106:3040
00:0f.0 Class 0300: 5333:8901 (rev 16)

And cat /proc/pci

PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: VIA Technologies, Inc. VT82C595/97 [Apollo VP2/97] (rev 3).
      Master Capable.  Latency=8.  
  Bus  0, device   2, function  0:
    Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang] (rev 0).
      IRQ 11.
      Master Capable.  Latency=64.  Min Gnt=3.Max Lat=8.
      I/O at 0x1480 [0x14bf].
  Bus  0, device   3, function  0:
    Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang] (#2) (rev 0).
      IRQ 11.
      Master Capable.  Latency=64.  Min Gnt=3.Max Lat=8.
      I/O at 0x14c0 [0x14ff].
  Bus  0, device   4, function  0:
    Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang] (#3) (rev 0).
      IRQ 11.
      Master Capable.  Latency=64.  Min Gnt=3.Max Lat=8.
      I/O at 0x1440 [0x147f].
  Bus  0, device   7, function  0:
    ISA bridge: VIA Technologies, Inc. VT82C586/A/B PCI-to-ISA [Apollo VP] (rev 49).
  Bus  0, device   7, function  1:
    IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 6).
      Master Capable.  Latency=66.  
      I/O at 0x1400 [0x140f].
  Bus  0, device   7, function  2:
    USB Controller: VIA Technologies, Inc. UHCI USB (rev 2).
      IRQ 11.
      Master Capable.  Latency=66.  
      I/O at 0x1420 [0x143f].
  Bus  0, device   7, function  3:
    Non-VGA unclassified device: VIA Technologies, Inc. VT82C586B ACPI (rev 0).
      I/O at 0x1000 [0x10ff].
  Bus  0, device  15, function  0:
    VGA compatible controller: S3 Inc. Trio 64V2/DX or /GX (rev 22).
      IRQ 11.
      Non-prefetchable 32 bit memory at 0x40000000 [0x43ffffff].
Comment 5 Mike A. Harris 2002-07-29 20:40:17 EDT
Does this still occur with the current Red Hat "Limbo" beta release?
There have been some bug fixes and other changes.

Please let me know as soon as possible.
Comment 6 Mike A. Harris 2002-11-04 03:29:51 EST
This problem is similar in nature to a number of problems on S3 hardware
that have been reported.  It is due to some infrastructure changes in the
distro WRT XFree86, which required Xconfigurator changes also but which
were not realized during development and beta testing, and nobody reported
any problems until the distro was already released.  There are no plans
to fix these problems in Xconfigurator now, as it affects few users only,
and there are wokrarounds that are simple enough to endure.

I'm closing this as a duplicate of another similar problem, you may want
to overview the duplicate bug report for more information also.

Comment 7 Mike A. Harris 2002-11-04 03:30:28 EST

*** This bug has been marked as a duplicate of 64544 ***

Note You need to log in before you can comment on or make changes to this bug.