Bug 64794 - hwbrowser hangs every time it is run
hwbrowser hangs every time it is run
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 19:45 EDT by Daryle Tilroe
Modified: 2013-04-02 00:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 11:13:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryle Tilroe 2002-05-10 19:45:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
When launching hwbrowser the small 'splash' window pops up and disappears, then the main 'Hardware Browser' window appears but it hangs partly drawn with 
empty white boxes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run 'hwbrowser' from menu or cli window
2.
3.
	

Actual Results:  The small 'splash' window pops up and disappears, then the main 'Hardware Browser' window appears but it hangs partly drawn with empty white 
boxes.

Expected Results:  A listing of all hardware.

Additional info:

These are the processes at hang time:

root      2460  0.0  0.1  2220  940 pts/0    S    16:57   0:00 /bin/sh /usr/share/hwbrowser/hwbrowser
root      2461  0.0  0.8 11412 7240 pts/0    D    16:57   0:02 /usr/bin/python /usr/share/hwbrowser/DeviceList.py
root      2462  0.0  0.0     0    0 pts/0    Z    16:57   0:00 [python <defunct>]

Only the first can be killed.  The latter two seem to need a reboot to get rid of.
Comment 1 Daryle Tilroe 2002-05-10 19:48:41 EDT
BTW the version of hwbrowser is '0.3.5-2' with a buld date of Aug. 29/01
Comment 2 Daryle Tilroe 2002-05-15 11:13:51 EDT
Turned out that the problem was using the stock 3wxxx.o driver for my 3ware 7410 ide raid card.  I compiled the latest 7.4 driver (1.02.00.019) with 
my kernel (2.4.9-31smp) and everything seems to work now.

Note You need to log in before you can comment on or make changes to this bug.