Bug 64803 - tput shouldn't be run in emacs shells
Summary: tput shouldn't be run in emacs shells
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-13 00:54 UTC by Reuben Thomas
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 21:59:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Reuben Thomas 2002-05-13 00:54:21 UTC
Description of Problem:

The line in /etc/bashrc saying

if [ -x /usr/bin/tput ]; then

should be

if [ "$TERM" != "emacs" -a -x /usr/bin/tput ]; then

so that tput is not run in emacs shells, which doesn't work.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Bill Nottingham 2002-05-13 15:12:33 UTC
This implies emacs doesn't have a proper termcap/terminfo entry.

Comment 2 Trond Eivind Glomsrxd 2002-05-14 23:07:42 UTC
What's the problem you're seeing? I'm not noticing anything when running shells
in emacs...

Comment 3 Reuben Thomas 2002-05-15 21:59:39 UTC
When I start a shell in xemacs (my own compiled version, but I have the emacs 
RPMs installed), I get:

"unknown terminal emacs"

Since I have emacs-21.2 installed, and there's no emacs entry in /etc/termcap (but 
there is an eterm), I presume there's something wrong. I will probably revert to the 
XEmacs RPMs now that you ship 21.4 in any case, but that shouldn't be the 
problem.

Comment 4 Trond Eivind Glomsrxd 2002-07-29 21:07:28 UTC
Closing, as I can start a shell multiple  ways in emacs and never see this.


Note You need to log in before you can comment on or make changes to this bug.