Bug 64818 - Initialization of VG fails at boot time per default
Initialization of VG fails at boot time per default
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lvm (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 02:52 EDT by Anders Norrbring
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 03:07:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Norrbring 2002-05-13 02:52:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The init of any and all volume groups will fail at boot time if the /usr file 
system is on its own partition.  This is due to that vgscan can't access the 
needed lib files at the point in rc.sysinit where init takes place as only the 
root file system is mounted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just reboot, it fails with errors about not being able to access lib files.
2.
3.
	

Expected Results:  I'd expect the rc.sysinit to init the volume groups.

Additional info:

After going through the rc.sysinit, I simply cut out the lvm init part and 
moved it downwards to just before quota init and added a line above it to 
mount /usr before the "Mount all local file systems" takes place. This works 
fine for me...  But maybe not everyone will find it.

If you have the /usr directory directly on the root volume I suspect the init 
will work as the lib files in /usr/libs will be accessible directly after the 
root remount, but it won't with /usr on its own partition.
Comment 1 Trond Eivind Glomsrxd 2002-05-14 18:13:32 EDT
Which version of lvm are you using? We didn't ship one in 7.2... and the one in
7.3 is only linked against libraries in /lib.
Comment 2 Anders Norrbring 2002-05-15 03:07:45 EDT
I'm using LVM v1.0.4, and it does install in /usr/lib and /sbin
Anyway, the problem is solved as I edited my rc.sysinit so I moved the LVM 
init downwards in the file (You've it put just below the /root remount per 
default) and I added a line to mount /usr (own partition) before LVM init, but 
before RAID init...
Comment 3 Trond Eivind Glomsrxd 2002-05-15 11:33:39 EDT
That package is not from us - I suggest you submit the bug to them.
(ours isn't 1.0.4, and doesn't have that problem)

Note You need to log in before you can comment on or make changes to this bug.